ITPub博客

首页 > Linux操作系统 > Linux操作系统 > PHP5中新增加的日期(date)函数的常量.

PHP5中新增加的日期(date)函数的常量.

原创 Linux操作系统 作者:php_itpub 时间:2008-07-30 08:55:56 0 删除 编辑
  PHP 5.1.1 起定义有以下常量来提供标准日期表达方法,可以用于日期格式函数(例如 date())。

  DATE_ATOM(string)

  原子钟格式(如:2005-08-15T15:52:01+00:00)

  DATE_COOKIE(string)

  HTTP Cookies 格式(如:Mon, 15 Aug 2005 15:52:01 UTC)

  DATE_ISO8601(string)

  ISO-8601(如:2005-08-15T15:52:01+0000)

  DATE_RFC822(string)

  RFC 822(如:Mon, 15 Aug 2005 15:52:01 UTC)

  DATE_RFC850(string)

  RFC 850(如:Monday, 15-Aug-05 15:52:01 UTC)

  DATE_RFC1036(string)

  RFC 1036(如:Monday, 15-Aug-05 15:52:01 UTC)

  DATE_RFC1123(string)

  RFC 1123(如:Mon, 15 Aug 2005 15:52:01 UTC)

  DATE_RFC2822(string)

  RFC 2822(如:Mon, 15 Aug 2005 15:52:01 +0000)

  DATE_RSS(string)

  RSS(如:Mon, 15 Aug 2005 15:52:01 UTC)

  DATE_W3C(string)

  World Wide Web Consortium(如:2005-08-15T15:52:01+00:00)

  比如,要输出一个RSS需要的日期格式,就可以用下面的代码简单实现:

  echo date(DATE_RSS);

来自 “ ITPUB博客 ” ,链接:https://blog.itpub.net/14883374/viewspace-413559/ ,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论

注册时间:2008-07-17

  • 博文量
    178
  • 访问量
    223494