ITPub博客

首页 > 数据库 > Oracle > 在RedHat enterprise server 3 安装oracle9i 2.0.0.1 并升级到9.2.0.6

在RedHat enterprise server 3 安装oracle9i 2.0.0.1 并升级到9.2.0.6

原创 Oracle 作者:ORA_WOLF 时间:2005-07-19 16:28:36 0 删除 编辑

oracle9i 2.0.4上个月从oracle网站下载没有安装在els3上。

参考了网上的一些文章,并根据文章的提示找了一些资料和补丁,完成了这次的安装。

[@more@]

1.安装RedHat EL3

现在的安装界面都做的很好了,一路NEXT就可以安装了.如果有困难,请参考其他linux安装文档进行.

注意:
需要安装开发工具.

最好将开发工具包安装全。


2.检查补丁

需要确认以下包都已经安装:

# rpm -qa | grep compat
compat-libstdc++-7.3-2.96.122
compat-gcc-c++-7.3-2.96.122
compat-libstdc++-devel-7.3-2.96.122
compat-db-4.0.14-5
compat-gcc-7.3-2.96.122

# rpm -qa | grep openmotif
openmotif21-2.1.30-8
# rpm -qa | grep setarch
setarch-1.3-1

如果有包没有安装,使用
# rpm -i compat...i386.rpm
命令来安装相应的包.

3.设置安装环境

需要将gcc,g++更换为2.96版本的.

# cd /usr/bin
# mv gcc gcc323
# mv g++ g++323
# ln -s gcc296 gcc
#ln -s g++296 g++

确认版本正确

# gcc -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux7/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.3 2.96-122)

# g++ -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux7/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.3 2.96-122)


登录为oracle用户
# su – oracle
$

检查环境变量

$ uname -a
Linux localhost.localdomain 2.4.21-4.EL #1 Fri Oct 3 18:13:58 EDT 2003 i686 i686 i386 GNU/Linux
$ rpm -qa | grep glibc
glibc-2.3.2-95.3

$ set | grep ORACLE
ORACLE_BASE=/app/oracle
ORACLE_HOME=/app/oracle/product/9.2.0.4.0
ORACLE_SID=oraapp

$ set | grep LD_ASSUME_KERNEL
LD_ASSUME_KERNEL=2.4.19
$

set 命令显示的结果中,必须有 ORACLE_HOME.

注意:
如果不设置LD_ASSUME_KERNEL, 则不能启动jre,也就不能启动安装界面.


4.从metalink下载必须的补丁

需要的补丁:

p3006854_9204_LINUX.zip 在运行 runInstaller 之前打.

p3095277_9204_LINUX.zip 的升级到9.2.0.4.0补丁包. 300多M
p2617419_210_GENERIC.zip 打3119415补丁所需要的补丁.
p3119415_9204_LINUX.zip 在升级到9.2.0.4.0之后打.

从9204升级到9.2.0.6的补丁,大约500多M

p3119415_9206_LINUX.zip升级到9.2.0.6后,要打得补丁。

说明: metalink上的文章说, 补丁 3119415在出现 ins_oemagent.mk link 错误时打,然后 retry. 经测试,安装过程中,这个补丁打不上去,报 oraInventory/ContentsXML/comps.xml不存在. 需要在安装完9204的补丁以后再打.

如何使用补丁, 请看后文.


5.开始安装9.2.0

运行runInstaller之前,需要打补丁3006854: 注意,必须以root身份运行.

# unzip p3006854_9204_LINUX.zip
Archive: p3006854_9204_LINUX.zip
creating: 3006854/
inflating: 3006854/rhel3_pre_install.sh
inflating: 3006854/README.txt

# cd 3006854
# sh rhel3_pre_install.sh

然后就可以运行runInstaller安装了.注意选择不要创建数据库.

Relink阶段,会出两个错误:ins_oemagent.mk 和 ins_ctx.mk. 点 Ignore 忽略.

如果还有其他疑问,请参考其它安装文章.


6.升级到9.2.0.4.0

安装结束后,HTTPD会自动运行.在升级之前,需要将它停下来.

$ cd /u01/app/oracle/product/9.2.0.4.0/Apache/Apache/bin
$ ./apachectl stop
./apachectl stop: httpd stopped

LISTENER也需要停下来.

$ lsnrctl stop

LSNRCTL for Linux: Version 9.2.0.1.0 - Production on 07-NOV-2003 16:25:41

Copyright (c) 1991, 2002, Oracle Corporation. All rights reserved.

Connecting to (ADDRESS=(PROTOCOL=tcp)(PORT=1521))
The command completed successfully

注意:
如果不停的话,oracle会抱怨不能覆盖文件.这个时候再去将服务停下来也可以,点Retry就可以了.


然后就可以开始打补丁升级了.

解包:

$ unzip p3095277_9204_LINUX.zip
Archive: p3095277_9204_LINUX.zip
inflating: 9204_lnx32_release.cpio
inflating: README.html
inflating: patchnote.css

$ cat 9204_lnx32_release.cpio | cpio -i --make-directories

现在可以运行runInstaller升级了.

注意:
首先要升级oui,否则不让升级到9.2.0.4.而且,升级完oui以后,要退出oui然后再重新运行oui,再升级到9.2.0.4.不退出继续升级有什么问题,metalink没有说,我也没有做测试.

升级过程中,仍然会出现ins_oemagent.mk错误,点 Ignore 忽略. 但 ins_ctx.mk 错误已经被修复,不出现了.


7.打补丁

升级过后,需要打补丁修复ins_oemagent.mk错误.

首先安装 opatch----p2617419_210_GENERIC.zip

主要产生Opatch这个应用文件。后续补丁的安装需要这个文件。

$ unzip p2617419_210_GENERIC.zip
Archive: p2617419_210_GENERIC.zip
creating: OPatch/
creating: OPatch/docs/
inflating: Opatch/docs/FAQ
......
inflating: README.txt
$ ls
$ pwd
/tmp/t

$ export PATH=$PATH:/tmp/t/OPatch:/sbin

注意:
修改PATH时,除了要包括解压出来的OPatch目录外,还要包括/sbin目录.这一点,metalink上没有说.


$ unzip p3119415_9204_LINUX.zip
Archive: p3119415_9204_LINUX.zip
creating: 3119415/
......
inflating: 3119415/README.txt

$ cd 3119415
$ opatch apply

就算安装成功了.

8、安装升级到9.2.0.6的升级文件

运行升级文件中的runInstaller文件

$./runInstaller

升级universal installer

升级universal installer成功后,退出installer。

重新运行runInstaller文件安装9.2.0.6的升级文件

升级成功后,运行补丁包p3119415_9206_LINUX.zip

$unzip p3119415_9206_LINUX.zip

$cd 3119415

$Opatch apply

安装补丁成功。

至此,oracle9i 从9.2.0.1.0 版本升级到9.2.0.6


9.运行dbca的问题.

在运行dbca, netca等图形工具之前,需要设置LD_ASSUME_KERNEL=2.4.19,否则不能启动JAVA.

刚才看笔记,发现漏了一个问题:

安装完9.2.0以后,以root身份运行root.sh会报错.不用管,升级到9.2.0.4以后,就没有问题了

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/9788/viewspace-802551/,如需转载,请注明出处,否则将追究法律责任。

上一篇: 可笑的菜名
下一篇: 没有了~
请登录后发表评论 登录
全部评论
  • 博文量
    3
  • 访问量
    151425