ITPub博客

首页 > 数据库 > Oracle > Oracle 10G数据库软硬件环境的要求

Oracle 10G数据库软硬件环境的要求

原创 Oracle 作者:chinazjq 时间:2007-08-21 11:06:05 0 删除 编辑
Oracle 10G数据库软硬件环境的要求[@more@]1.检查硬件要求


系统必须符合以下最低硬件要求:


至少有1024MB的物理内存


下表说明安装时物理内存(RAM)和交换区(swap space)的配置关系。


RAM Swap Space


1024 MB 到 2048 MB 1.5 倍 RAM


2049 MB 到 8192 MB 等于 RAM


大于 8192 MB 0.75 倍 RAM


在 /tmp 目录中至少有400 MB空闲磁盘空间


1.5 GB 到 3.5 GB 的磁盘空间用于安装 Oracle 数据库软件,具体大小由安装类型决定


1.2GB 磁盘空间用于数据库预配置文件系统存储(可选)


说明:


使用 ASM (Automatic Storage Management) 和 RDS (raw device storage) 的磁盘空间要求在后面的章节中描述。


若选择自动备份配置,启用闪回区(flash recovery area)需要额外的磁盘空间,也可以在文件系统或 ASM(Automatic Storage Management) 磁盘组中指定。


确保系统满足这些要求:


确认物理内存尺寸,键入下列命令:


# grep MemTotal /proc/meminfo


如果物理内存尺寸小于推荐的内存要求,必须在安装前增加内存。


确认交换区(swap space)尺寸,键入下列命令:


# grep SwapTotal /proc/meminfo


示例:


as3$grep SwapTotal /proc/meminfo


SwapTotal: 2048248 kB


必要时,查阅操作系统文档中如何配置额外交换区(swap space)的相关信息以修改交换区(swap space)配置。


确认可用的 RAM 和交换区(swap space),键入下列命令:


# free


示例:


as3$free


total used free shared buffers cached


Mem: 503084 490356 12728 0 2432 345224


-/+ buffers/cache: 142700 360384


Swap: 2048248 72692 1975556


最好在延迟数秒后,作多次重复测试.


说明:


上述命令会产生多个不同的结果。这是因为在冻结期外可用的 RAM 和交换区(swap space)随用户的操作不断变化。


确认 /tmp 目录中可用的磁盘空间,键入下列命令:


# df -h /tmp


示例:


as3$df -h /tmp


文件系统 容量 已用 可用 已用% 挂载点


/dev/hda3 16G 4.5G 11G 31% /


如果在 /tmp 目录的自由磁盘空间中少于 400MB,请完成下列步骤之一:


删除 /tmp 目录中不必要的文件以满足磁盘空间需求。


在配置Oracle 用户环境时设置 TEMP 和 TMPDIR 环境变量(稍后说明)。


扩充文件系统的 /tmp 目录。必要时,联系您的系统管理员了解关于扩充文件系统的相关信息。


确认操作系统的自由磁盘空间,键入下列命令:


# df -h


示例:


as3$df -h


文件系统 容量 已用 可用 已用% 挂载点


/dev/hda3 16G 4.5G 11G 31% /


/dev/hda2 981M 27M 905M 3% /boot


/dev/hda5 29G 27G 1.3G 96% /opt


none 246M 0 246M 0% /dev/shm


/dev/hda6 15G 191M 14G 2% /var


下表显示每种安装类型需要的大约磁盘空间:


安装类型 所需空间


Enterprise Edition 1.85


Standard Edition 1.85


Custom (maximum) 1.99


确认系统硬件架构能运行 Oracle 软件,键入下列命令:


# grep "model name" /proc/cpuinfo


示例:


as3$grep "model name" /proc/cpuinfo


model name : Intel(R) Pentium(R) 4 CPU 2.80GHz


说明:


该命令显示处理器类型。验证处理器架构匹配您将要安装的 Oracle 发行版软件。如果看不到预期结果,则不能在系统中安装这个软件。








2.检查软件要求


安装所需的软件环境,根据下表进行核实。


说明:


Oracle 通用安装工具根据系统需求清单对系统进行检查核实。确保在开始安装前通过检查。


需求项


操作系统 包含下列操作系统版本之一:


Red Hat Enterprise Linux AS/ES 3.0 (Update 4 or later)


Red Hat Linux 4.0 (Update 1 or later)


SUSE Linux Enterpreise Server 8.0 with SP4 or later


SUSE Linux Enterprise Server 9.0 with SP2 or later


核心版本 系统必须运行在以下核心版本之上(或以上版本):


Red Hat Enterprise Linux 3.0:


2.4.21-20.EL


Red Hat Enterprise Linux 4.0:


2.6.9-11.EL


SUSE Linux Enterprise Server 8.0:


2.4.21-278


SUSE Linux Enterprise Server 9.0:


2.6.5-139


包 下列包(或以上版本)必须已经安装:


Red Hat Enterprise Linux 3.0:


make-3.79.1-17


control-center-2.2.0.1-13


gcc-3.2.3-47


gcc-c++-3.2.3-47


gdb-6.1post-1.20040607.52


glibc-2.3.2-95.30


glibc-common-2.3.2-95.30


glibc-devel-2.3.2-95.30


glibc-devel-2.3.2-95.20 (32 bit)


compat-db-4.0.14-5.1


compat-gcc-7.3-2.96.128


compat-gcc-c++-7.3-2.96.128


compat-libstdc++-7.3-2.96.128


compat-libstdc++-devel-7.3-2.96.128


gnome-libs-1.4.1.2.90-34.2 (32 bit)


libstdc++-3.2.3-47


libstdc++-devel-3.2.3-47


openmotif-2.2.3-3.RHEL3


sysstat-5.0.5-5.rhel3


setarch-1.3-1


libaio-0.3.96-3


libaio-devel-0.3.96-3


Red Hat Enterprise Linux 4.0:


binutils-2.15.92.0.2-10.EL4


compat-db-4.1.25-9


control-center-2.8.0-12


gcc-3.4.3-9.EL4


gcc-c++-3.4.3-9.EL4


glibc-2.3.4-2


glibc-common-2.3.4-2


gnome-libs-1.4.1.2.90-44.1


libstdc++-3.4.3-9.EL4


libstdc++-devel-3.4.3-9.EL4


make-3.80-5


pdksh-5.2.14-30


sysstat-5.0.5-1


xscreensaver-4.18-5.rhel4.2


SUSE Linux Enterprise Server 9:


gcc-3.3.3


gcc-c++-3.3.3


glibc-2.3.3


libaio-0.3.102-1.2ia64


libaio-devel-0.3.102-1.2ia64


make-3.80


PL/SQL 本地编译, Pro*C/C++, Oracle 调用接口, Oracle C++ 调用接口, Oracle XML 开发工具 (XDK) Intel C++ 编译器 8.1 或 GNU C and C++ 编译器及以上版本,这些产品需要以上清单所列出的包支持。


说明:


Intel C++ 编译器 V8.1 以上已经提供支持,不需要安装。在 Red Hat Enterprise Linux 3, OCCI上采用 3.2 版,已经提供 GNU C++ 编译器支持。这是默认的编译器版本。OCCI 也同样支持采用 gcc 3.2.3 标准模板库的 Intel C++ 编译器 V8.1。


Oracle XML 开发套件 在使用 GCC 的 Red Hat Linux 4.0 上不被支持。只有 Intel C++ 编译器 (ICC) 提供支持。


在 Red Hat Enterprise Linux 4.0 上, Oracle C++ 调用接口 (OCCI) 不支持 GCC 3.4.3。要在 Red Hat Enterprise Linux 4.0 上使用 OCCI,你需要安装 GCC 3.2.3。


Oracle JDBC/OCI 驱动程序 你可以在下列 JDK 版本中使用 Oracle JDBC/OCI 驱动;然而,它们不需要单独安装:


Sun JDK 1.4.2 with the JNDI extension


说明:JDK 1.4.2 在该发行版中已经安装


确保系统满足这些要求:


确认 Linux 版本,键入下列命令:


# cat /etc/issue


示例:


as3$cat /etc/issue


Red Hat Enterprise Linux AS release 3 (Taroon)


Kernel
on an m


说明:


只有存在先前表格中所列版本的 Linux 被支持。不能安装在其他的 Linux 版本上。


确认需要的核心已经安装,键入下列命令:


# uname -r


示例:


as3$uname -r


2.4.21-4.ELsmp


下面是该命令在一个 Red Hat Enterprise Linux 3.0 系统中执行的输出情形:


2.4.21-20.EL


在该例中,输出表明系统的核心版本 ()和 勘误表 (20.EL)等级。


新的内核命名


RHAS2.1 for ia32


2.4.9-e.25 ― 单处理器内核


2.4.9-e.25-smp ― 能够处理最高达 4GB 的物理内存的 SMP 内核


2.4.9-e.25 ― 能够处理最高达 16GB 左右的物理内存的企业 SMP 内核


RHEL3 for ia32


2.4.21-4.EL ― 单处理器内核


2.4.21-4.ELsmp ― 能够处理最高达 16 GB 的物理内存的 SMP 内核


2.4.21-4.ELhugemem ― 能够处理超过 16 GB,最高达 64 GB 的 SMP 内核


如果核心版本不符合前述要求,请与操作系统供应商联系,以获取最新的核心版本并更新。


确认必须的包已经全部安装,请键入下列格式类似的命令:


# rpm -q package_name


示例:


as3$rpm -q gcc-3.3.3


package gcc-3.3.3 is not installed


如果包没有安装,请从您的 Linux 安装包或从 Linux 提供商的网址下载并安装。


如果需要为 WebSphereMQ 的 CSD,请在下列网址中下载并获取安装信息:


http://www.ibm.com/software/integration/mqfamily/support/summary/lin.html

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/9723916/viewspace-964697/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论

注册时间:2008-01-04

  • 博文量
    9
  • 访问量
    156879