ITPub博客

首页 > Linux操作系统 > Linux操作系统 > 遇到"ORA-39700: 必须用 UPGRADE 选项打开数据库"问题

遇到"ORA-39700: 必须用 UPGRADE 选项打开数据库"问题

原创 Linux操作系统 作者:treesofthehill 时间:2012-05-10 09:58:32 0 删除 编辑

升级oracle10g,启动oracle时出现以下错误:

ORA-00704: 引导程序进程失败
ORA-39700: 必须用 UPGRADE 选项打开数据库

网上搜索了一下,发现需要配置一下才能启动oracle。

步骤如下:

1.startup upgrade 启动数据库。

2.在sqlplus里执行catupgrd.sql脚本,这个脚本用于重建数据字典视图脚本。

3然后重启数据库后,再执行utlrp.sql脚本,这个脚本用于编译无效对象。

4再次重启数据库,解决ora 39700.

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/9537053/viewspace-723206/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论

注册时间:2008-06-11

  • 博文量
    97
  • 访问量
    175240