ITPub博客

首页 > Linux操作系统 > Linux操作系统 > win7 for 64位安装oracle 10.2.0.4 client

win7 for 64位安装oracle 10.2.0.4 client

原创 Linux操作系统 作者:听海★蓝心梦 时间:2011-05-28 08:00:22 0 删除 编辑

操作系统:win7 旗舰版 for 64bit

oracle版本:10204_vista_w2k8_x32_production_client

报错信息:

正在检查操作系统要求...
要求的结果: 5.0,5.1,5.2,6.0 之一
实际结果: 6.1

 

解决办法:

database安装:

找到 refhost.xml 文件(位置:database\stage\prereq\db,打开 refhost.xml 配置文件并找到 节点,接着在节点后面修改6.0至6.1

client安装:

找到 refhost.xml 文件(位置:F:\10204_vista_w2k8_x32_production_client\stage\prereq\client,打开 refhost.xml 配置文件并找到 节点,接着在节点后面修改6.0至6.1

<!--Microsoft Windows 7-->


再次安装,一切正常。

 

或者可以直接下载10204_vista_w2k8_x64_production_client直接安装在win7 for 64bit操作系统,但是该客户端在导出oracle 11.0.1.6数据库的时候报错:

导出了                                                            99 行
. 正在导出同义词
. 正在导出视图
. 正在导出存储过程
. 正在导出运算符
EXP-00008: 遇到 ORACLE 错误 904
ORA-00904: "OLEVEL": 标识符无效
EXP-00000: 导出终止失败

 

网上很多人都遇到这个错误,是因为高版本客户端导出低版本数据库导致,但是我用的是10204_vista_w2k8_x64_production_client客户端导出11g的数据库,仍然有该问题,怀疑是64位客户端有问题,所以安装32位的客户端验证一下。

 

安装32位的客户端做导出:

导出了                                                           109 行
. 正在导出同义词
. 正在导出视图
. 正在导出存储过程
. 正在导出运算符
. 正在导出引用完整性约束条件
. 正在导出触发器
. 正在导出索引类型
. 正在导出位图, 功能性索引和可扩展索引
. 正在导出后期表活动
. 正在导出实体化视图
. 正在导出快照日志
. 正在导出作业队列
. 正在导出刷新组和子组
. 正在导出维
. 正在导出 post-schema 过程对象和操作
. 正在导出统计信息
成功终止导出, 没有出现警告。

果然没有问题,看来的确是64位的客户端造成的。不过不明白是为什么,64位的操作系统难道不能用64位的客户端?

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/751371/viewspace-696484/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论

注册时间:2009-02-18

  • 博文量
    256
  • 访问量
    1202323