ITPub博客

首页 > 人工智能 > 人工智能 > 升级macOS12后Alfred for mac无法运行PHP插件怎么办?

升级macOS12后Alfred for mac无法运行PHP插件怎么办?

原创 人工智能 作者:miqi_1998 时间:2021-10-07 10:17:18 0 删除 编辑

这次macOS12测试版里做了非常多的改动,继续保持对Intel 系列的反向优化功能。软件层里面也不断去除了旧的内置支持,比如已经删除了 /usr/bin/php , 所以导致 Alfred 的很多插件无法正常使用了。虽然可以通过homebrew或者macports等第三方包管理软件,安装上PHP软件包,但是它并不能安装到原来的路径,现在折中的办法就是先调用 /bin/bash 然后再传\{query\}参数给PHP脚本了,具体如下:

  • 解析器路径指向切到 /bin/bash
  • 把原来的脚本复制出来,贴成另一个独立的PHP脚本文件,比如foundIt.php
  • 传递参数调整到{query} 
  • /opt/local/bin/php74 foundIt.php $1

  • foundIt.php文件保存在plugin的同级目录下就可以了。

右键这个插件,打开Finder,就可以到达同级目录。

修改原来的传递参数,注释掉的是旧的。因为原来整个php脚本是在alfred里运行,现在改成独立脚本后,需要从命令行参数1里获取了。

// $orig = "{query}";
$orig = "$argv[1]";

最后经过这番修改,我们又可以愉快地运行原来的php写的alfred插件了。如此方法后,大家应该临时能用上php的插件了。还是希望alfred本身对路径支持进行修改,不然每次这次弄还是挺麻烦的。macOS12底层还是经历了非常多的改动,像这次的php内置支持移除,普通用户从表面上根本是无法感知的。

随着2021年十月份macOS 的发布,苹果应该是从软件底层为剔除 intel 代码做准备了,参考上次苹果的迁移,也只用了一代系统就完成了从 PowerPC 到 Intel 架构的转变,中间就是 Mac OS X 10.5 保持了对 PowerPC 的兼容性支持,到了下一个 10.6 的时代就完全不支持 PowerPC了。

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/69983423/viewspace-2794791/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论

注册时间:2020-09-09

  • 博文量
    158
  • 访问量
    76182