ITPub博客

首页 > Linux操作系统 > Linux操作系统 > ASM 模块安装与操作系统内核版本问题

ASM 模块安装与操作系统内核版本问题

原创 Linux操作系统 作者:xchui702 时间:2011-08-05 17:37:56 0 删除 编辑

配置ASM 出错:
[root@standby tmp]# /etc/init.d/oracleasm config
Usage: /etc/init.d/oracleasm {start|stop|restart|enable|disable|configure|createdisk|deletedisk|querydisk|listdisks|scandisks|status}
[root@standby tmp]# /etc/init.d/oracleasm configure
Configuring the Oracle ASM library driver.

This will configure the on-boot properties of the Oracle ASM library
driver.  The following questions will determine whether the driver is
loaded on boot and what permissions it will have.  The current values
will be shown in brackets ('[]').  Hitting without typing an
answer will keep that current value.  Ctrl-C will abort.

Default user to own the driver interface [oracle]:
Default group to own the driver interface [oinstall]:
Start Oracle ASM library driver on boot (y/n) [y]:
Fix permissions of Oracle ASM disks on boot (y/n) [y]:
Writing Oracle ASM library driver configuration:           [  OK  ]
Loading module "oracleasm": Unable to load module "oracleasm"
                                                           [FAILED]


因为 内核版本是2.6.9-42.0.0.0.1.ELsmp, 而当前的ASM 版本是oracleasm-2.6.9-42.0.0.0.1.EL,不匹配。        
[root@standby 2.6.9-42.0.0.0.1.EL]# rpm -qa | grep -i asm
ibmasm-3.0-7
oracleasm-2.6.9-42.0.0.0.1.EL-2.0.3-2
oracleasmlib-2.0.2-1
oracleasm-support-2.0.3-2

[root@standby 2.6.9-42.0.0.0.1.EL]# uname -a
Linux standby 2.6.9-42.0.0.0.1.ELsmp #1 SMP Sun Oct 15 14:02:40 PDT 2006 i686 i686 i386 GNU/Linux

然后安装oracleasm-2.6.9-42.0.2.ELsmp-2.0.3-1.i686.rpm 也不成功,因为内核版本是2.6.9-42.0.0.0.1.ELsmp 而非oracleasm-2.6.9-42.0.2.ELsmp 所以也安装不上。
[root@standby 2.6.9-42.0.0.0.1.EL]# rpm -ivh /tmp/oracleasm-2.6.9-42.0.2.ELsmp-2.0.3-1.i686.rpm
error: Failed dependencies:
        kernel-smp = 2.6.9-42.0.2.EL is needed by oracleasm-2.6.9-42.0.2.ELsmp-2.0.3-1.i6  

--既然oracle linux, 会提供ASM的支持,那么一定会有对应该操作系统的ASM 模块。在安装光盘第三章盘上找到对应内核版本的ASM模块:
[root@standby RPMS]# rpm -ivh oracleasm-2.6.9-42.0.0.0.1.ELsmp-2.0.3-2.i686.rpm
warning: oracleasm-2.6.9-42.0.0.0.1.ELsmp-2.0.3-2.i686.rpm: V3 DSA signature: NOKEY, key ID b38a8516
Preparing...                ########################################### [100%]
   1:oracleasm-2.6.9-42.0.0.########################################### [100%]

重新配置ASM 模块: 就能配置成功了。
[root@standby RPMS]# rpm -ivh oracleasm-2.6.9-42.0.0.0.1.ELsmp-2.0.3-2.i686.rpm
warning: oracleasm-2.6.9-42.0.0.0.1.ELsmp-2.0.3-2.i686.rpm: V3 DSA signature: NOKEY, key ID b38a8516
Preparing...                ########################################### [100%]
   1:oracleasm-2.6.9-42.0.0.########################################### [100%]
[root@standby RPMS]# /etc/init.d/oracleasm configure
Configuring the Oracle ASM library driver.

This will configure the on-boot properties of the Oracle ASM library
driver.  The following questions will determine whether the driver is
loaded on boot and what permissions it will have.  The current values
will be shown in brackets ('[]').  Hitting without typing an
answer will keep that current value.  Ctrl-C will abort.

Default user to own the driver interface [oracle]:
Default group to own the driver interface [oinstall]:
Start Oracle ASM library driver on boot (y/n) [y]:
Fix permissions of Oracle ASM disks on boot (y/n) [y]:
Writing Oracle ASM library driver configuration:           [  OK  ]
Loading module "oracleasm":                                [  OK  ]
Mounting ASMlib driver filesystem:                         [  OK  ]
Scanning system for ASM disks:
                                                           [  OK  ]

可以查看模块:
[root@standby RPMS]# lsmod | grep -i asm
oracleasm              48020  1

或者:
[root@standby oracleasm]# pwd
/lib/modules/2.6.9-42.0.0.0.1.ELsmp/kernel/drivers/addon/oracleasm
[root@standby oracleasm]# ls -l
total 352
-rw-r--r--  1 root root 349666 Oct 25  2006 oracleasm.ko

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/674865/viewspace-704301/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论

注册时间:2011-05-16

  • 博文量
    38
  • 访问量
    121478