ITPub博客

首页 > Linux操作系统 > Linux操作系统 > 编译过程导致ORA-4068错误

编译过程导致ORA-4068错误

原创 Linux操作系统 作者:yangtingkun 时间:2012-05-19 23:56:25 0 删除 编辑

一个10203上的bug,这种问题还是第一次碰到。

 

 

10.2.0.3上,存在bug可能导致编译过程或视图失败,而失败的结果并不只是当前视图或过程不可用,而是可能影响整个数据字典,导致存储过程在执行时出现ORA-4068错误。

错误信息如下:

ORA-04068: existing state of packages has been discarded.
ORA-04065: not executed, altered or dropped stored procedure P_PACKAGE.P_PRO
ORA-06508: PL/SQL: could not find program unit being called: P_PACKAGE.P_PRO
ORA-06512: at line 1

这个问题对应的BUG信息为:Bug 6136074 - ORA-4068 / ORA-4065 ORA-6508 on VALID objects [ID 6136074.8],导致问题的原因就是编译对象时导致PLSQL的依赖对象的时间戳发生不一致,从而导致问题的产生。

Oracle文档上给出了检查问题的SQL语句:

select do.obj# d_obj,do.name d_name, do.type# d_type,
po.obj# p_obj,po.name p_name,
to_char(p_timestamp,'DD-MON-YYYY HH24:MI:SS') "P_Timestamp",
to_char(po.stime ,'DD-MON-YYYY HH24:MI:SS') "STIME",
decode(sign(po.stime-p_timestamp),0,'SAME','*DIFFER*') X
from sys.obj$ do, sys.dependency$ d, sys.obj$ po
where P_OBJ#=po.obj#(+)
and D_OBJ#=do.obj#
and do.status=1 /*dependent is valid*/
and po.status=1 /*parent is valid*/
and po.stime!=p_timestamp /*parent timestamp not match*/
order by 2,1;

通过这个脚本将获取的对象进行重新编译,可以解决这个问题,要避免问题的再次出现,应该将数据库版本升级到10.2.0.4以上。

 

 

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/4227/viewspace-730561/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论
暂无介绍

注册时间:2007-12-29

  • 博文量
    1955
  • 访问量
    10351221