ITPub博客

首页 > Linux操作系统 > Linux操作系统 > 安装RDAC for RedHatl inux as5 (64bit) 需要安装ibm多路径软件的dba们可以参考下

安装RDAC for RedHatl inux as5 (64bit) 需要安装ibm多路径软件的dba们可以参考下

原创 Linux操作系统 作者:sunchao 时间:2019-04-24 22:57:04 0 删除 编辑
硬件环境:
IBM 3950级联
IBM DS4800机头 exp810 sata盘柜 exp810光纤盘柜
先看系统:
[root@ykt ~]# uname -a
Linux ykt 2.6.18-8.el5xen #1 SMP Fri Jan 26 14:29:35 EST 2007 x86_64 x86_64 x86_64 GNU/Linux

为了避免安装过程中出现不必要的错误,参考网上资料把相关rpm安装包打上:
[root@ykt kernels]# rpm -qa|grep kernel
kernel-PAE-devel-2.6.18-53.el5
kernel-xen-2.6.18-8.el5
kernel-2.6.18-8.el5
kernel-headers-2.6.18-8.el5
kernel-xen-devel-2.6.18-53.el5
kernel-PAE-2.6.18-53.el5
kernel-devel-2.6.18-53.el5
kernel-PAE-devel-2.6.18-8.el5
[root@ykt kernels]# rpm -qa|grep compat
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp.112
java-1.4.2-gcj-compat-1.4.2.0-40jpp.112
compat-libf2c-34-3.4.6-4
compat-libstdc++-33-3.2.3-61
compat-db-4.2.52-5.1
java-1.4.2-gcj-compat-src-1.4.2.0-40jpp.112
compat-glibc-headers-2.3.4-2.26
compat-gcc-34-c++-3.4.6-4
compat-libstdc++-33-3.2.3-61
compat-glibc-2.3.4-2.26
compat-db-4.2.52-5.1
compat-libstdc++-296-2.96-138
compat-glibc-2.3.4-2.26
compat-gcc-34-g77-3.4.6-4
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp.112
compat-gcc-34-3.4.6-4
compat-libgcc-296-2.96-138
[root@ykt kernels]# rpm -qa|grep sysstat
sysstat-7.0.0-3.el5


将 rdac-LINUX-09.02.C5.13-source.tar.gz 拷贝到/tmp下
[root@ykt tmp]# ls -l rdac-LINUX-09.02.C5.13-source.tar.gz
-rwxr-xr-x 1 root root 329888 03-07 03:17 rdac-LINUX-09.02.C5.13-source.tar.gz

解压 rdac-LINUX-09.02.C5.13-source.tar.gz
[root@ykt tmp]# cd linuxrdac-09.02.C5.13/

该包中包含如下文件:
[root@ykt linuxrdac-09.02.C5.13]# ls
genfileattributes  mppCmn_s2tos3.c        mpp_linux_sys_headers      mppLnx26p_vhbalib.c   mppSupport
genuniqueid.c      mppCmn_SysInterface.c  mppLnx26p_spinlock_size.c  mppLnx26p_vhbamisc.c  Readme.txt
hbaCheck           mpp.conf               mppLnx26p_sysdep.c         mppLnx26p_vhbaproc.c  setupDriver.REDHAT
License.txt        MPP_hba.c              mppLnx26p_upper.c          mppLnx26p_vhbatask.c  setupDriver.SUSE
lsvdev             mppiscsi_umountall     mppLnx26p_vhba.c           mpp_rcscript.REDHAT   utility
Makefile           mpp_linux_headers      mppLnx26p_vhbaio.c         mpp_rcscript.SUSE

虽然做了准备,但是安装的过程中还是出现了问题:
[root@ykt linuxrdac-09.02.C5.13]#make V=0 -C/lib/modules/2.6.18-8.el5xen/build  M=/tmp/linuxrdac-09.02.C5.13 MODVERDIR=/lib/modules/2.6.18-8.el5xen/build/.tmp_versions SUBDIRS=/tmp/linuxrdac-09.02.C5.13 modules
9B$b W(x9O'Tdo0make: *** /lib/modules/2.6.18-8.el5xen/build: No such file or directory.  Stop.
m;H^o0RF/X7K xw V0make: *** [mppUpper] Error 2

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/39335/viewspace-563304/,如需转载,请注明出处,否则将追究法律责任。

下一篇: top 10 sql
请登录后发表评论 登录
全部评论

注册时间:2003-03-08

  • 博文量
    677
  • 访问量
    502236