ITPub博客

首页 > IT基础架构 > 网络安全 > WPA2安全加密协议概念验证代码现已发布

WPA2安全加密协议概念验证代码现已发布

网络安全 作者:安全剑客 时间:2019-10-08 14:01:12 0 删除 编辑
发现WPA2 安全加密协议漏洞的安全专家现已发布密钥重装攻击的概念验证代码供爱好者进行验证以及测试。

脚本测试原理是断开WiFi连接的情况下不断地尝试扫描,然后开始让无线接入点重新安装密钥达到测试目的。

当然安全专家不会直接发布攻击 脚本防止出现安全性问题,脚本主要是检测客户端与AP接入点间是否受影响。

测试验证步骤:(Kail  Linux为例)
1、首先我们需要下载多个组件所以此时请连接你的网络,当然具体是有线连接还是WiFi无线网络连接都行:

// 更新系统然后安装如下组件:

apt-get update
apt-get install libnl-3-dev libnl-genl-3-dev pkg-config libssl-dev net-tools git sysfsutils python-scapy python-pycryptodome
2、安装完成后请前往网络管理器中断开WiFi连接,然后执行下列 命令确保测试脚本可以持续使用WiFi:
sudo rfkill unblock wifi
3、接下来我们就可以执行KRACK重装攻击的测试脚本了,直接在终端中执行以下 命令即可(脚本结尾提供)
/krack-ft-test.py --help
4、在脚本执行完毕后如果显示的是Vulnerable那么说明设备受到影响,如果是 Invulnerable 则不会受影响。
[15:48:47] AP transmitted data using IV=5 (seq=4)
[15:48:47] AP transmitted data using IV=5 (seq=4)
[15:48:47] IV reuse detected (IV=5, seq=4). AP is vulnerable! <== 受到影响

原文地址: https://www.linuxprobe.com/wpa2-secure-release.html

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/31559985/viewspace-2659020/,如需转载,请注明出处,否则将追究法律责任。

上一篇: 玩转SVN-启动模式
请登录后发表评论 登录
全部评论

注册时间:2018-11-01

  • 博文量
    631
  • 访问量
    397661