ITPub博客

首页 > 应用开发 > Python > Python3.7与Python2.7在centos7下兼容并存

Python3.7与Python2.7在centos7下兼容并存

Python 作者:安全剑客 时间:2019-09-21 22:28:33 0 删除 编辑

Python3.7与Python2.7在centos7下兼容并存Python3.7与Python2.7在centos7下兼容并存
1、下载python3.7

wget "https://www.python.org/ftp/python/3.7.0/Python-3.7.0.tgz"

2、解压下载好的压缩包

tar -zxvf Python-3.7.0.tgz

3、配置编译python3.7

mkdir /usr/local/python3
cd Python-3.7.0
./configure --prefix=/usr/local/python3
make
make install

(make install的时候如果报如下错:ModuleNotFoundError: No module named '_ctypes',是因为3.7版本需要新的包libffi-devel,使用如下 命令安装即可: yum install libffi-devel -y ;然后再make install)

4、配置环境变量

修改 /etc/profile 文件,在文件末尾加上如下两行代码

PATH=$PATH:/usr/local/python3/bin
export PATH

最后执行 命令 source /etc/profile 或执行点命令 ./profile 使其修改生效.

原文地址: https://www.linuxprobe.com/python-centos7-compatible.html

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/31559985/viewspace-2657838/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论

注册时间:2018-11-01

  • 博文量
    637
  • 访问量
    402032