ITPub博客

首页 > 数据库 > Oracle > Oracle软件安装需要的软件包

Oracle软件安装需要的软件包

Oracle 作者:sambatuzi 时间:2020-09-06 02:38:38 0 删除 编辑

1   安装12c

1.1   Table 3 x86-64 Supported Linux 7 Operating System Requirements

Item

Requirements

SSH Requirement

Ensure that OpenSSH is installed on your servers. OpenSSH is the required SSH software.

Oracle Linux 7

Subscribe to the Oracle Linux 7 channel on the Unbreakable Linux Network, or configure a yum repository from the Oracle public yum site, and then install the Oracle Preinstallation RPM. This RPM installs all required kernel packages for Oracle Grid Infrastructure and Oracle Database installations, and performs other system configuration.

Supported distributions:

Oracle Linux 7 with the Unbreakable Enterprise kernel: 3.8.13-33.el7uek.x86_64 or later

Oracle Linux 7 with the Red Hat Compatible kernel: 3.10.0-123.el7.x86_64 or later

Red Hat Enterprise Linux 7

Supported distributions:

Red Hat Enterprise Linux 7: 3.10.0-123.el7.x86_64 or later

Packages for Oracle Linux 7 and Red Hat Enterprise Linux 7

The following packages (or later versions) must be installed:

binutils-2.23.52.0.1-12.el7.x86_64

compat-libcap1-1.10-3.el7.x86_64

compat-libstdc++-33-3.2.3-71.el7.i686

compat-libstdc++-33-3.2.3-71.el7.x86_64

gcc-4.8.2-3.el7.x86_64

gcc-c++-4.8.2-3.el7.x86_64

glibc-2.17-36.el7.i686

glibc-2.17-36.el7.x86_64

glibc-devel-2.17-36.el7.i686

glibc-devel-2.17-36.el7.x86_64

ksh

libaio-0.3.109-9.el7.i686

libaio-0.3.109-9.el7.x86_64

libaio-devel-0.3.109-9.el7.i686

libaio-devel-0.3.109-9.el7.x86_64

libgcc-4.8.2-3.el7.i686

libgcc-4.8.2-3.el7.x86_64

libstdc++-4.8.2-3.el7.i686

libstdc++-4.8.2-3.el7.x86_64

libstdc++-devel-4.8.2-3.el7.i686

libstdc++-devel-4.8.2-3.el7.x86_64

libXi-1.7.2-1.el7.i686

libXi-1.7.2-1.el7.x86_64

libXtst-1.2.2-1.el7.i686

libXtst-1.2.2-1.el7.x86_64

make-3.82-19.el7.x86_64

sysstat-10.1.5-1.el7.x86_64



1.2   Table 4 x86-64 Supported Linux 6 Operating System Requirements

Item

Requirements

SSH Requirement

Ensure that OpenSSH is installed on your servers. OpenSSH is the required SSH software.

Oracle Linux 6

Subscribe to the Oracle Linux 6 channel on the Unbreakable Linux Network, or configure a yum repository from the Oracle public yum site, and then install the Oracle Preinstallation RPM. This RPM installs all required kernel packages for Oracle Grid Infrastructure and Oracle Database installations, and performs other system configuration.

Supported distributions:

Oracle Linux 6 with the Unbreakable Enterprise Kernel (UEK):

Update 2 or higher, 2.6.39-200.24.1.el6uek.x86_64 or later UEK2 kernels

Update 4 or higher, 3.8.13-16 or later UEK3 kernels

Update 7 or higher, 4.1.12-32 or later UEK4 kernels

Oracle Linux 6 with the Red Hat Compatible kernel: 2.6.32-71.el6.x86_64 or later

Red Hat Enterprise Linux 6

Supported distributions:

Red Hat Enterprise Linux 6: 2.6.32-71.el6.x86_64 or later

Packages for Oracle Linux 6 and Red Hat Enterprise Linux 6

The following packages (or later versions) must be installed:

binutils-2.20.51.0.2-5.11.el6 (x86_64)

compat-libcap1-1.10-1 (x86_64)

compat-libstdc++-33-3.2.3-69.el6 (x86_64)

compat-libstdc++-33-3.2.3-69.el6 (i686)

gcc-4.4.4-13.el6 (x86_64)

gcc-c++-4.4.4-13.el6 (x86_64)

glibc-2.12-1.7.el6 (i686)

glibc-2.12-1.7.el6 (x86_64)

glibc-devel-2.12-1.7.el6 (x86_64)

glibc-devel-2.12-1.7.el6 (i686)

ksh

libgcc-4.4.4-13.el6 (i686)

libgcc-4.4.4-13.el6 (x86_64)

libstdc++-4.4.4-13.el6 (x86_64)

libstdc++-4.4.4-13.el6 (i686)

libstdc++-devel-4.4.4-13.el6 (x86_64)

libstdc++-devel-4.4.4-13.el6 (i686)

libaio-0.3.107-10.el6 (x86_64)

libaio-0.3.107-10.el6 (i686)

libaio-devel-0.3.107-10.el6 (x86_64)

libaio-devel-0.3.107-10.el6 (i686)

libXext-1.1 (x86_64)

libXext-1.1 (i686)

libXtst-1.0.99.2 (x86_64)

libXtst-1.0.99.2 (i686)

libX11-1.3 (x86_64)

libX11-1.3 (i686)

libXau-1.0.5 (x86_64)

libXau-1.0.5 (i686)

libxcb-1.5 (x86_64)

libxcb-1.5 (i686)

libXi-1.3 (x86_64)

libXi-1.3 (i686)

make-3.81-19.el6

sysstat-9.0.4-11.el6 (x86_64)


1.3   Table 5 x86-64 Supported Linux 5 Operating System Requirements

Item

Requirements

SSH Requirement

Ensure that OpenSSH is installed on your servers. OpenSSH is the required SSH software.

Oracle Linux 5

Subscribe to the Oracle Linux 5 channel on the Unbreakable Linux Network, and then install the Oracle Validated RPM. This RPM installs all required kernel packages for Oracle Grid Infrastructure and Oracle Database installations, and performs other system configuration.

Supported distributions:

Oracle Linux 5 Update 6 with the Unbreakable Enterprise kernel: 2.6.32-100.0.19 or later

Oracle Linux 5 Update 6 with the Red Hat compatible kernel: 2.6.18-238.0.0.0.1.el5 or later

Red Hat Enterprise Linux 5

Supported distributions:

Red Hat Enterprise Linux 5 Update 6: 2.6.18-238.0.0.0.1.el5 or later

Package requirements for Oracle Linux 5 and Red Hat Enterprise Linux 5

The following packages (or later versions) must be installed:

binutils-2.17.50.0.6

compat-libstdc++-33-3.2.3

compat-libstdc++-33-3.2.3 (32 bit)

gcc-4.1.2

gcc-c++-4.1.2

glibc-2.5-58

glibc-2.5-58 (32 bit)

glibc-devel-2.5-58

glibc-devel-2.5-58 (32 bit)

ksh

libaio-0.3.106

libaio-0.3.106 (32 bit)

libaio-devel-0.3.106

libaio-devel-0.3.106 (32 bit)

libgcc-4.1.2

libgcc-4.1.2 (32 bit)

libstdc++-4.1.2

libstdc++-4.1.2 (32 bit)

libstdc++-devel 4.1.2

libXext-1.0.1

libXext-1.0.1 (32 bit)

libXtst-1.0.1

libXtst-1.0.1 (32 bit)

libX11-1.0.3

libX11-1.0.3 (32 bit)

libXau-1.0.1

libXau-1.0.1 (32 bit)

libXi-1.0.1

libXi-1.0.1 (32 bit)

make-3.81

sysstat-7.0.2


1.4   Table 6 x86-64 Supported SUSE Operating System Requirements

Item

Requirements

SSH Requirement

Ensure that OpenSSH is installed on your servers. OpenSSH is the required SSH software.

SUSE Linux Enterprise Server 11

Supported distribution:

SUSE Linux Enterprise Server 11 SP2: 3.0.13-0.27 or later

SUSE Linux Enterprise Server 12

Supported distribution:

SUSE Linux Enterprise Server 12 SP1: 3.12.49-11 or later

SUSE 11

The following packages (or later versions) must be installed:

binutils-2.21.1-0.7.25

gcc-4.3-62.198

gcc-c++-4.3-62.198

glibc-2.11.3-17.31.1

glibc-devel-2.11.3-17.31.1

ksh-93u-0.6.1

libaio-0.3.109-0.1.46

libaio-devel-0.3.109-0.1.46

libcap1-1.10-6.10

libstdc++33-3.3.3-11.9

libstdc++33-32bit-3.3.3-11.9

libstdc++43-devel-4.3.4_20091019-0.22.17

libstdc++46-4.6.1_20110701-0.13.9

libgcc46-4.6.1_20110701-0.13.9

make-3.81

sysstat-8.1.5-7.32.1

xorg-x11-libs-32bit-7.4

xorg-x11-libs-7.4

xorg-x11-libX11-32bit-7.4

xorg-x11-libX11-7.4

xorg-x11-libXau-32bit-7.4

xorg-x11-libXau-7.4

xorg-x11-libxcb-32bit-7.4

xorg-x11-libxcb-7.4

xorg-x11-libXext-32bit-7.4

xorg-x11-libXext-7.4

SUSE 12

The following packages (or later versions) must be installed:

binutils-2.25.0-13.1

gcc-4.8-6.189

gcc48-4.8.5-24.1

glibc-2.19-31.9

glibc-32bit-2.19-31.9

glibc-devel-2.19-31.9.x86_64

glibc-devel-32bit-2.19-31.9.x86_64

mksh-50-2.13

libaio1-0.3.109-17.15

libaio-devel-0.3.109-17.15

libcap1-1.10-59.61

libstdc++48-devel-4.8.5-24.1.x86_64

libstdc++48-devel-32bit-4.8.5-24.1.x86_64

libstdc++6-5.2.1+r226025-4.1.x86_64

libstdc++6-32bit-5.2.1+r226025-4.1.x86_64

libstdc++-devel-4.8-6.189.x86_64

libstdc++-devel-32bit-4.8-6.189.x86_64

libgcc_s1-5.2.1+r226025-4.1.x86_64

libgcc_s1-32bit-5.2.1+r226025-4.1.x86_64

make-4.0-4.1.x86_64

sysstat-10.2.1-3.1.x86_64

xorg-x11-driver-video-7.6_1-14.30.x86_64

xorg-x11-server-7.6_1.15.2-36.21.x86_64

xorg-x11-essentials-7.6_1-14.17.noarch

xorg-x11-Xvnc-1.4.3-7.2.x86_64

xorg-x11-fonts-core-7.6-29.45.noarch

xorg-x11-7.6_1-14.17.noarch

xorg-x11-server-extra-7.6_1.15.2-36.21.x86_64

xorg-x11-libs-7.6-45.14.noarch

xorg-x11-fonts-7.6-29.45.noarch


1.5   Supported NeoKylin Linux Advanced Server Distributions for x86-64

Use the following information to check supported NeoKylin Linux Advanced Server distributions:

Note:

Starting with Oracle Database 12c Release 1 (12.1.0.2), NeoKylin Linux Advanced Server 6 is certified on Linux x86-64 systems.

Table 7 x86-64 Supported NeoKylin Minimum Operating System Requirements

Item

Requirements

SSH Requirement

Ensure that OpenSSH is installed on your servers. OpenSSH is the required SSH software.

NeoKylin Linux Advanced Server

Supported distribution:

NeoKylin Linux Advanced Server 6: 2.6.32-431.el6.x86_64 or later

NeoKylin 6.0

The following packages (or later versions) must be installed:

binutils-2.20.51.0.2-5.36.el6 (x86_64)

compat-libcap1-1.10-1 (x86_64)

compat-libstdc++-33-3.2.3-69.el6 (x86_64)

compat-libstdc++-33-3.2.3-69.el6 (i686)

gcc-4.4.7-4.el6 (x86_64)

gcc-c++-4.4.7-4.el6 (x86_64)

glibc-2.12-1.132.el6 (i686)

glibc-2.12-1.132.el6 (x86_64)

glibc-devel-2.12-1.132.el6 (x86_64)

glibc-devel-2.12-1.132.el6 (i686)

ksh

libgcc-4.4.7-4.el6 (i686)

libgcc-4.4.7-4.el6 (x86_64)

libstdc++-4.4.7-4.el6 (x86_64)

libstdc++-4.4.7-4.el6 (i686)

libstdc++-devel-4.4.7-4.el6 (x86_64)

libstdc++-devel-4.4.7-4.el6 (i686)

libaio-0.3.107-10.el6 (x86_64)

libaio-0.3.107-10.el6 (i686)

libaio-devel-0.3.107-10.el6 (x86_64)

libaio-devel-0.3.107-10.el6 (i686)

libXext-1.3.1-2.el6 (x86_64)

libXext-1.3.1-2.el6 (i686)

libXtst-1.2.1-2.el6 (x86_64)

libXtst-1.2.1-2.el6 (i686)

libX11-1.5.0-4.el6 (x86_64)

libX11-1.5.0-4.el6 (i686)

libXau-1.0.6-4.el6 (x86_64)

libXau-1.0.6-4.el6 (i686)

libxcb-1.8.1-1.el6 (x86_64)

libxcb-1.8.1-1.el6 (i686)

libXi-1.6.1-3.el6 (x86_64)

libXi-1.6.1-3.el6 (i686)

make-3.81-20.el6

sysstat-9.0.4-22.el6 (x86_64)


2   安装11g

The following are the list of packages required for Oracle Database 11g Release 2 (11.2):

Oracle Database Package Requirements for Linux x86

Oracle Database Package Requirements for Linux x86-64

Oracle Database Package Requirements for IBM: Linux on System z

Note:

Oracle recommends that you install your Linux operating system with the default software packages (RPMs), unless you specifically intend to perform a minimal installation and follow the directions for performing such an installation to ensure that you have all required packages for Oracle software.

Oracle recommends that you do not customize RPMs during a default operating system installation. A default installation includes most required packages and helps you to limit manual verification of package dependencies.

If you did not perform a default Linux installation, you intend to use LDAP, and you want to use the scripts odisrvreg, oidca, or schemasync, then install the Korn shell RPM for the Linux distribution.

You must install the packages (or later versions) listed in the following table, and ensure that the list of RPMs and all of the prerequisites for these RPMs are installed.

See Also:

"About Installing the Linux Operating System" for information about installing Oracle Validated RPM

"Installing the cvuqdisk Package for Linux"

2.1   Oracle Database Package Requirements for Linux x86


Operating System

Requirement

Oracle Linux 4 and Red Hat Enterprise Linux 4

The following packages (or later versions) must be installed:

binutils-2.15.92.0.2

compat-libstdc++-33-3.2.3

elfutils-libelf-0.97

elfutils-libelf-devel-0.97

gcc-3.4.6

gcc-c++-3.4.6

glibc-2.3.4-2.41

glibc-common-2.3.4

glibc-devel-2.3.4

glibc-headers-2.3.4

libaio-devel-0.3.105

libaio-0.3.105

libgcc-3.4.6

libstdc++-3.4.6

libstdc++-devel-3.4.6

make-3.80

numactl-0.6.4.i386

pdksh-5.2.14

sysstat-5.0.5

Asianux Server 3, Oracle Linux 5, and Red Hat Enterprise Linux 5

The following packages (or later versions) must be installed:

binutils-2.17.50.0.6

compat-libstdc++-33-3.2.3

elfutils-libelf-0.125

elfutils-libelf-devel-0.125

elfutils-libelf-devel-static-0.125

gcc-4.1.2

gcc-c++-4.1.2

glibc-2.5-24

glibc-common-2.5

glibc-devel-2.5

glibc-headers-2.5

kernel-headers-2.6.18

ksh-20060214

libaio-0.3.106

libaio-devel-0.3.106

libgcc-4.1.2

libgomp-4.1.2

libstdc++-4.1.2

libstdc++-devel-4.1.2

make-3.81

sysstat-7.0.2

Oracle Linux 6 and Red Hat Enterprise Linux 6

The following packages (or later versions) must be installed:

binutils-2.20.51.0.2-5.11.el6.i686

compat-libcap1-1.10-1.i686

compat-libstdc++-33-3.2.3-69.el6.i686

gcc-4.4.4-13.el6.i686

gcc-c++-4.4.4-13.el6.i686

glibc-2.12-1.7.el6.i686

glibc-devel-2.12-1.7.el6.i686

ksh

libgcc-4.4.4-13.el6.i686

libstdc++-4.4.4-13.el6.i686

libstdc++-devel-4.4.4-13.el6.i686

libaio-0.3.107-10.el6.i686

libaio-devel-0.3.107-10.el6.i686

make-3.81-19.el6.i686

sysstat-9.0.4-11.el6.i686

SUSE Linux Enterprise Server 10

The following packages (or later versions) must be installed:

binutils-2.16.91.0.5

compat-libstdc++-5.0.7

gcc-4.1.2

gcc-c++-4.1.2

glibc-2.4-31.63

glibc-devel-2.4-31.63

ksh-93r-12.9

libaio-0.3.104

libaio-devel-0.3.104

libelf-0.8.5

libgcc-4.1.2

libstdc++-4.1.2

libstdc++-devel-4.1.2

make-3.80

sysstat-8.0.4

SUSE Linux Enterprise Server 11

The following packages (or later versions) must be installed:

binutils-2.19

gcc-4.3

gcc-c++-4.3

glibc-2.9

glibc-devel-2.9

ksh-93t

libstdc++33-3.3.3

libstdc++43-4.3.3_20081022

libstdc++43-devel-4.3.3_20081022

libaio-0.3.104

libaio-devel-0.3.104

libgcc43-4.3.3_20081022

libstdc++-devel-4.3

make-3.81

sysstat-8.1.5

 

Note:

The kernel-headers-2.6.18 package is not mandatory for database installations on Linux x86. You can ignore the OUI or CVU warning to install this package.

The numa package link for Linux x86 is /usr/lib.

Oracle Database Package Requirements for Linux x86-64

Note:

Starting with Oracle Database 11g Release 2 (11.2.0.2), all the 32-bit packages, except for gcc-32bit-4.3, listed in the following table are no longer required for installing a database on Linux x86-64. Only the 64-bit packages are required. However, for any Oracle Database 11g release before 11.2.0.2, both the 32-bit and 64-bit packages listed in the following table are required.

If you are using Oracle Unbreakable Enterprise Kernel, then all required kernel packages are installed as part of the Oracle Unbreakable Enterprise Kernel installation.

For Orace Linux 6 the Oracle Validated RPM has been replaced by the Oracle RDBMS Server 11gR2 Pre-install RPM. See  "Completing a Minimal Linux Installation" for more information.

Operating System

Requirement

Oracle Linux 4 and Red Hat Enterprise Linux 4

The following packages (or later versions) must be installed:

binutils-2.15.92.0.2

compat-libstdc++-33-3.2.3

compat-libstdc++-33-3.2.3 (32 bit)

elfutils-libelf-0.97

elfutils-libelf-devel-0.97

expat-1.95.7

gcc-3.4.6

gcc-c++-3.4.6

glibc-2.3.4-2.41

glibc-2.3.4-2.41 (32 bit)

glibc-common-2.3.4

glibc-devel-2.3.4

glibc-headers-2.3.4

libaio-0.3.105

libaio-0.3.105 (32 bit)

libaio-devel-0.3.105

libaio-devel-0.3.105 (32 bit)

libgcc-3.4.6

libgcc-3.4.6 (32-bit)

libstdc++-3.4.6

libstdc++-3.4.6 (32 bit)

libstdc++-devel 3.4.6

make-3.80

numactl-0.6.4.x86_64

pdksh-5.2.14

sysstat-5.0.5

Asianux Server 3, Oracle Linux 5, and Red Hat Enterprise Linux 5

The following packages (or later versions) must be installed:

binutils-2.17.50.0.6

compat-libstdc++-33-3.2.3

compat-libstdc++-33-3.2.3 (32 bit)

elfutils-libelf-0.125

elfutils-libelf-devel-0.125

gcc-4.1.2

gcc-c++-4.1.2

glibc-2.5-24

glibc-2.5-24 (32 bit)

glibc-common-2.5

glibc-devel-2.5

glibc-devel-2.5 (32 bit)

glibc-headers-2.5

ksh-20060214

libaio-0.3.106

libaio-0.3.106 (32 bit)

libaio-devel-0.3.106

libaio-devel-0.3.106 (32 bit)

libgcc-4.1.2

libgcc-4.1.2 (32 bit)

libstdc++-4.1.2

libstdc++-4.1.2 (32 bit)

libstdc++-devel 4.1.2

make-3.81

sysstat-7.0.2

Oracle Linux 6 and Red Hat Enterprise Linux 6

The following packages (or later versions) must be installed:

binutils-2.20.51.0.2-5.11.el6 (x86_64)

compat-libcap1-1.10-1 (x86_64)

compat-libstdc++-33-3.2.3-69.el6 (x86_64)

compat-libstdc++-33-3.2.3-69.el6.i686

gcc-4.4.4-13.el6 (x86_64)

gcc-c++-4.4.4-13.el6 (x86_64)

glibc-2.12-1.7.el6 (i686)

glibc-2.12-1.7.el6 (x86_64)

glibc-devel-2.12-1.7.el6 (x86_64)

glibc-devel-2.12-1.7.el6.i686

ksh

libgcc-4.4.4-13.el6 (i686)

libgcc-4.4.4-13.el6 (x86_64)

libstdc++-4.4.4-13.el6 (x86_64)

libstdc++-4.4.4-13.el6.i686

libstdc++-devel-4.4.4-13.el6 (x86_64)

libstdc++-devel-4.4.4-13.el6.i686

libaio-0.3.107-10.el6 (x86_64)

libaio-0.3.107-10.el6.i686

libaio-devel-0.3.107-10.el6 (x86_64)

libaio-devel-0.3.107-10.el6.i686

make-3.81-19.el6

sysstat-9.0.4-11.el6 (x86_64)

SUSE Linux Enterprise Server 10

The following packages (or later versions) must be installed:

binutils-2.16.91.0.5

compat-libstdc++-5.0.7

gcc-4.1.0

gcc-c++-4.1.2

glibc-2.4-31.63

glibc-devel-2.4-31.63

glibc-devel-32bit-2.4-31.63

ksh-93r-12.9

libaio-0.3.104

libaio-32bit-0.3.104

libaio-devel-0.3.104

libaio-devel-32bit-0.3.104

libelf-0.8.5

libgcc-4.1.2

libstdc++-4.1.2

libstdc++-devel-4.1.2

make-3.80

numactl-0.9.6.x86_64

sysstat-8.0.4

SUSE Linux Enterprise Server 11

The following packages (or later versions) must be installed:

binutils-2.19

gcc-4.3

gcc-32bit-4.3

gcc-c++-4.3

glibc-2.9

glibc-32bit-2.9

glibc-devel-2.9

glibc-devel-32bit-2.9

ksh-93t

libaio-0.3.104

libaio-32bit-0.3.104

libaio-devel-0.3.104

libaio-devel-32bit-0.3.104

libstdc++33-3.3.3

libstdc++33-32bit-3.3.3

libstdc++43-4.3.3_20081022

libstdc++43-32bit-4.3.3_20081022

libstdc++43-devel-4.3.3_20081022

libstdc++43-devel-32bit-4.3.3_20081022

libgcc43-4.3.3_20081022

libstdc++-devel-4.3

make-3.81

sysstat-8.1.5

 

Note:

The numa package link for Linux x86-64 is /usr/lib64/.

Oracle Database Package Requirements for IBM: Linux on System z

Operating System

Requirement

Red Hat Enterprise Linux 4

The following packages (or later versions) must be installed:

binutils-2.15.92.0.2-25 (s390x)

compat-libstdc++-33-3.2.3-47.3 (s390)

compat-libstdc++-33-3.2.3-47.3 (s390x)

gcc-3.4.6-11 (s390x)

gcc-c++-3.4.6-11 (s390x)

glibc-2.3.4-2.43 (s390)

glibc-2.3.4-2.43 (s390x)

glibc-devel-2.3.4-2.43 (s390)

glibc-devel-2.3.4-2.43 (s390x)

libaio-0.3.105-2 (s390)

libaio-0.3.105-2 (s390x)

libaio-devel-0.3.105-2 (s390)

libaio-devel-0.3.105-2 (s390x)

libgcc-3.4.6-11 (s390)

libgcc-3.4.6-11 (s390x)

libstdc++-3.4.6-10.0.1

libstdc++-3.4.6-10.0.1 (32-bit)

libstdc++-devel-3.4.6-10.0.1

libstdc++-devel-3.4.6-10.0.1 (x86_64)

make-3.80

pdksh

sysstat-5.0.5-25.el4 (s390x)

Red Hat Enterprise Linux 5

The following packages (or later versions) must be installed:

binutils-2.17.50.0.6-12.el5 (s390x)

compat-libstdc++-33-3.2.3-61 (s390)

compat-libstdc++-33-3.2.3-61 (s390x)

gcc-4.1.2-46.el5 (s390x)

gcc-c++-4.1.2-46.el5 (s390x)

glibc-2.5-42(s390)

glibc-2.5-42 (s390x)

glibc-devel-2.5-42 (s390)

glibc-devel-2.5-42 (s390x)

ksh

libaio-0.3.106-3.2 (s390)

libaio-0.3.106-3.2 (s390x)

libaio-devel-0.3.106-3.2 (s390)

libaio-devel-0.3.106-3.2 (s390x)

libgcc-4.1.2-46.el5 (s390)

libgcc-4.1.2-46.el5 (s390x)

libstdc++-4.1.2-46.el5 (s390)

libstdc++-4.1.2-46.el5 (s390x)

libstdc++-devel-4.1.2-46.el5 (s390x)

make-3.81

sysstat-7.0.2-3.el5 (s390x)

Red Hat Enterprise Linux 6

The following packages (or later versions) must be installed:

binutils-2.20.51.0.2-5.28 (s390x)

compat-libstdc++-33-3.2.3-69.el6 (s390x)

gcc-4.4.6-3.el6 (s390x)

gcc-c++-4.4.6-3.el6 (s390x)

glibc-2.12-1.47.el6 (s390)

glibc-2.12-1.47.el6 (s390x)

glibc-devel-2.12-1.47.el6 (s390)

glibc-devel-2.12-1.47.el6 (s390x)

libaio-0.3.107-10.el6 (s390)

libaio-0.3.107-10.el6 (s390x)

libaio-devel-0.3.107-10.el6 (s390x)

libgcc-4.4.6-3.el6 (s390)

libgcc-4.4.6-3.el6 (s390x)

libstdc++-4.4.6-3.el6 (s390x)

libstdc++-devel-4.4.6-3.el6 (s390x)

make-3.81-19.el6 (s390x)

pdksh

sysstat-9.0.4-18.el6 (s390x)

SUSE Linux Enterprise Server 10

The following packages (or later versions) must be installed:

binutils-32bit-2.16.91.0.5-23.34.33 (s390x)

gcc-4.1.2_20070115-0.29.6 (s390x)

gcc-c++-4.1.2_20070115-0.29.6 (s390x)

glibc-2.4-31.74.1 (s390x)

glibc-32bit-2.4-31.74.1 (s390x)

glibc-devel-2.4-31.74.1 (s390x)

glibc-devel-32bit-2.4-31.74.1 (s390x)

ksh

libaio-0.3.104-14.2 (s390x)

libaio-32bit-0.3.104-14.2 (s390x)

libaio-devel-0.3.104-14.2 (s390x)

libaio-devel-32bit-0.3.104-14.2 (s390x)

libstdc++-4.1.2_20070115-0.29.6 (s390x)

libstdc++-devel-4.1.2_20070115-0.29.6 (s390x)

make-3.80-202.2 (s390x)

sysstat-8.0.4-1.7.27 (s390x)

SUSE Linux Enterprise Server 11

The following packages (or later versions) must be installed:

binutils-2.20.0-0.7.9 (s390x)

gcc-4.3-62.198 (s390x)

gcc-c++-4.3-62.198 (s390x)

glibc-2.11.1-0.17.4 (s390x)

glibc-32bit-2.11.1-0.17.4 (s390x)

glibc-devel-2.11.1-0.17.4 (s390x)

glibc-devel-32bit-2.11.1-0.17.4 (s390x)

ksh

libaio-0.3.109-0.1.46 (s390x)

libaio-32bit-0.3.109-0.1.46 (s390x)

libaio-devel-0.3.109-0.1.46 (s390x)

libaio-devel-32bit-0.3.109-0.1.46 (s390x)

libstdc++43-4.3.4_20091019-0.7.35 (s390x)

libstdc++43-32bit-4.3.4_20091019-0.7.35 (s390x)

libstdc++43-devel-4.3.4_20091019-0.7.35 (s390x)

libstdc++43-devel-32bit-4.3.4_20091019-0.7.35 (s390x)

libgcc43-4.3.4_20091019-0.7.35 (s390x)

make-3.81

sysstat-8.1.5-7.9.56 (s390x)

 

See  "Oracle ODBC Drivers" for information on ODBC packages.

To determine if the required packages are installed, enter commands similar to the following:

# rpm -q package_name

If a package is not installed, then install it from the Linux distribution media or download the required package version from the Linux vendor's Web site.


3   10g

The following is the list of supported Linux versions and requirements at the time of release:

Software Requirements List for x86 (32-bit) Platforms

Software Requirements List for x86 (64-bit) Platforms

Software Requirements List for Linux on Itanium

Software Requirements List for Linux on POWER

Software Requirements list for IBM zSeries Based Linux

3.1   Software Requirements List for x86 (32-bit) Platforms

Table 2-1 Linux x86 (32-bit) System Requirements

Item

Requirement

Operating system x86

Red Hat Enterprise Linux AS/ES 3 (Update 3 or later)

Red Hat Enterprise Linux AS/AS 4 (Update 1 or later)

SUSE Linux Enterprise Server 9 (Service Pack 2 or later)

Kernel version

The system must be running the following kernel version (or a later version):

Red Hat Enterprise Linux 3 (Update 4):

2.4.21-27.EL

Red Hat Enterprise Linux 4 (Update 1):

2.6.9-11.EL

SUSE Linux Enterprise Server 9 (Service Pack 2):

2.6.5-7.97

Red Hat Enterprise Linux 3 (Update 2) Packages

The following packages (or later versions) must be installed:

binutils-2.14

 

compat-db-4.0.14-5

 

compat-gcc-7.3-2.96.128

 

compat-gcc-c++-7.3-2.96.128

 

compat-libstdc++-7.3-2.96.128

 

compat-libstdc++-devel-7.3-2.96.128

 

gcc-3.2

 

glibc-2.3.2-95.27

 

make-3.79

 

openmotif-2.2.3

 

setarch-1.3-1

 

Red Hat Enterprise Linux 4 (Update 1) Packages

The following packages (or later versions) must be installed:

binutils-2.15.92.0.2-10.EL4

 

compat-db-4.1.25-9

 

control-center-2.8.0-12

 

gcc-3.4.3-9.EL4

 

gcc-c++-3.4.3-9.EL4

 

glibc-2.3.4-2

 

glibc-common-2.3.4-2

 

gnome-libs-1.4.1.2.90-44.1

 

libstdc++-3.4.3-9.EL4

 

libstdc++-devel-3.4.3-9.EL4

 

make-3.80-5

 

Note:

openmotif21-2.1.30-11.RHEL4.2 is required to install Oracle demos.

GNU Compiler Collection (GCC) 2.96 is not supported on Red Hat Enterprise Linux 4.0.

SUSE Linux Enterprise Server 9 (Service Pack 2) Packages

gcc-3.3

 

gcc-c++-3.3.3-43

 

glibc-2.3.3-98.28

 

libaio-0.3.98-18

 

libaio-devel-0.3.98-18

 

make-3.80

 

openmotif-libs-2.2.2-519.1

 

PL/SQL native compilation, Pro*C/C++, Oracle Call Interface, Oracle C++ Call Interface, Oracle XML Developer's Kit (XDK)

The version of GNU C and C++ compilers listed previously for your distribution is supported for use with these products.

Oracle JDBC/OCI Drivers

On x86-64 systems, you can use the following optional JDK version with the Oracle JDBC/OCI drivers; however, it is not required for the installation:

JDK 1.4.2_03 with the JNDI extension

 

Oracle Real Application Clusters

For a cluster file system, use one of the following options:

Red Hat 3: Oracle Cluster File System (OCFS)

Version 1.0.11-1 or later

OCFS requires the following kernel packages:

ocfs-support

 

ocfs-tools

 

ocfs-kernel_version

In the preceding list, the variable kernel_version represents the kernel version of the operating system on which you are installing OCFS.

Note: OCFS is required only if you want to use a cluster file system for database file storage. If you want to use Automatic Storage Management or raw devices for database file storage, then you do not need to install OCFS.

Obtain OCFS kernel packages, installation instructions, and additional information about OCFS from the following URL:

Red Hat 4: Oracle Cluster File System 2 (OCFS2)

Version 1.0.1-1 or later

For information about Oracle Cluster File System version 2, refer to the following Web site:

For OCFS2 certification status, refer to the Certify page on OracleMetaLink.

SUSE 9: Oracle Cluster File System 2 (OCFS2)

OCFS2 is bundled with SuSE Linux Enterprise Server 9, Service Pack 2 or higher.

If you are running SUSE 9,then ensure that you are upgraded to the latest kernel (Service Pack 2 or higher), and ensure that you have installed the packages ocfs2-tools and ocfs2console.

For OCFS2 certification status, refer to the Certify page on OracleMetaLink.

 

3.2   Software Requirements List for x86 (64-bit) Platforms

Table 2-2 Linux x86 (64-bit) System Requirements

Item

Requirement

Operating systems x86 (64-bit)

Red Hat Enterprise Linux AS/ES 3 (Update 4 or later)

Red Hat Enterprise Linux AS/ES 4 (Update 1 or later)

SUSE Linux Enterprise Server 9 (Service Pack 2 or later)

Kernel version x86

The system must be running one of the following kernel versions (or a later version):

Red Hat Enterprise Linux 3 (Update 4):

2.4.21-27.EL

Note: This is the default kernel version.

Red Hat Enterprise Linux 4 (Update 1):

2.6.9-11.EL

SUSE Linux Enterprise Server 9 (Service Pack 2):

2.6.5-7.201

Red Hat Enterprise Linux 3 (Update 4) Packages

The following packages (or later versions) must be installed:

make-3.79.1-17

 

compat-db 4.0.14-5.1

 

control-center-2.2.0.1-13

 

gcc-3.2.3-47

 

gcc-c++-3.2.3-47

 

gdb-6.1post-1.20040607.52

 

glibc-2.3.2-95.30

 

glibc-common-2.3.2-95.30

 

glibc-devel-2.3.2-95.30

 

glibc-devel-2.3.2-95.20 (32 bit)

 

glibc-devel-2.3.4-2.13.i386 (32-bit)

 

compat-db-4.0.14-5

 

compat-gcc-7.3-2.96.128

 

compat-gcc-c++-7.3-2.96.128

 

compat-libstdc++-7.3-2.96.128

 

compat-libstdc++-devel-7.3-2.96.128

 

gnome-libs-1.4.1.2.90-34.2 (32 bit)

 

libstdc++-3.2.3-47

 

libstdc++-devel-3.2.3-47

 

openmotif-2.2.3-3.RHEL3

 

sysstat-5.0.5-5.rhel3

 

setarch-1.3-1

 

libaio-0.3.96-3

 

libaio-devel-0.3.96-3

 

Note: XDK is not supported with gcc on Red Hat Enterprise Linux 3.

Red Hat Enterprise Linux 4 (Update 1):Packages

The following packages (or later versions) must be installed:

binutils-2.15.92.0.2-10.EL4

binutils-2.15.92.0.2-13.0.0.0.2.x86_64

 

compat-db-4.1.25-9

 

control-center-2.8.0-12

 

gcc-3.4.3-9.EL4

 

gcc-c++-3.4.3-9.EL4

 

glibc-2.3.4-2

 

glibc-common-2.3.4-2

 

gnome-libs-1.4.1.2.90-44.1

 

libstdc++-3.4.3-9.EL4

 

libstdc++-devel-3.4.3-9.EL4

 

make-3.80-5

 

Note: XDK is not supported with gcc on Red Hat Enterprise Linux 4.

SUSE Linux Enterprise Server 9 Packages

The following packages (or later versions) must be installed:

binutils-2.15.90.0.1.1-32.5

 

gcc-3.3.3-43.24

 

gcc-c++-3.3.3-43.24

 

glibc-2.3.3-98.28

 

gnome-libs-1.4.1.7-671.1

 

libstdc++-3.3.3-43.24

 

libstdc++-devel-3.3.3-43.24

 

make-3.80-184.1

 

PL/SQL native compilation, Pro*C/C++, Oracle Call Interface, Oracle C++ Call Interface, Oracle XML Developer's Kit (XDK)

Intel C++ Compiler 8.1 or later and the version of GNU C and C++ compilers listed previously for the distribution are supported for use with these products.

Note: Intel C++ Compiler v8.1 or later is supported. However, it is not required for installation.

On Red Hat Enterprise Linux 3, Oracle C++ Call Interface (OCCI) is supported with version 2.2 of the GNU C++ compiler. This is the default compiler version. OCCI is also supported with Intel Compiler v8.1 with gcc 3.2.3 standard template libraries.

On Red Hat Enterprise Linux 4.0, OCCI does not support GCC 3.4.3. To use OCCI on Red Hat Enterprise Linux 4.0, you need to install GCC 3.2.3.

Oracle XML Developer's Kit is not supported with GCC on Red Hat Linux 4.0. It is supported only with Intel C++ Compiler (ICC).

Oracle JDBC/OCI Drivers

You can use the following optional JDK versions with the Oracle JDBC/OCI drivers; however, they are not required for the installation:

Sun JDK 1.5.0 (64-bit)

Sun JDK 1.5.0 (32-bit)

Sun JDK 1.4.2_09 (32-bit)

Oracle Real Application Clusters

For a cluster file system, use one of the following options:

Red Hat 3: Oracle Cluster File System (OCFS)

Version 1.0.13-1 or later

OCFS requires the following kernel packages:

ocfs-support

 

ocfs-tools

 

ocfs-kernel_version

In the preceding list, the variable kernel_version represents the kernel version of the operating system on which you are installing OCFS.

Note: OCFS is required only if you want to use a cluster file system for database file storage. If you want to use Automatic Storage Management or raw devices for database file storage, then you do not need to install OCFS.

Obtain OCFS kernel packages, installation instructions, and additional information about OCFS from the following URL:

Red Hat 4: Oracle Cluster File System 2 (OCFS2)

Version 1.0.1-1 or later

For information about Oracle Cluster File System version 2, refer to the following Web site:

For OCFS2 certification status, refer to the Certify page on OracleMetaLink.

SUSE 9: Oracle Cluster File System 2 (OCFS2)

OCFS2 is bundled with SuSE Linux Enterprise Server 9, Service Pack 2 or higher.

If you are running SUSE9, then ensure that you are upgraded to the latest kernel (Service Pack 2 or higher), and ensure that you have installed the packages ocfs2-tools and ocfs2console.

For OCFS2 certification status, refer to the Certify page on OracleMetaLink.

 

3.3   Software Requirements List for Linux on Itanium

Table 2-3 Linux Itanium (64-bit) System Requirements

Item

Requirement

Operating systems

Red Hat Enterprise Linux AS/ES 3.0 (Update 3 or later)

Red Hat Enterprise Linux AS/ES 4.0 (Update 1 or later)

SUSE Linux Enterprise Server 9.0 (Service Pack 2 or later)

Kernel version Itanium

The system must be running one of the following kernel versions (or a later version):

Red Hat Enterprise Linux 3.0:

2.4.21-278.EL

Red Hat Enterprise Linux 4.0:

2.6.9-11.EL

SUSE Linux Enterprise Server 9:

2.6.5-139

Packages Red Hat Enterprise Linux 3.0

make-3.79.1-17

 

control-center-2.2.0.1-13

 

gcc-3.2.3-47

 

gcc-c++-3.2.3-47

 

gdb-6.1post-1.20040607.52

 

glibc-2.3.2-95.30

 

glibc-common-2.3.2-95.30

 

glibc-devel-2.3.2-95.30

 

glibc-devel-2.3.2-95.20 (32 bit)

 

glibc-devel-2.3.4-2.13.i386 (32-bit)

 

compat-db-4.0.14-5.1

 

compat-gcc-7.3-2.96.128

 

compat-gcc-c++-7.3-2.96.128

 

compat-libstdc++-7.3-2.96.128

 

compat-libstdc++-devel-7.3-2.96.128

 

gnome-libs-1.4.1.2.90-34.2 (32 bit)

 

libstdc++-3.2.3-47

 

libstdc++-devel-3.2.3-47

 

openmotif-2.2.3-3.RHEL3

 

sysstat-5.0.5-5.rhel3

 

setarch-1.3-1

 

libaio-0.3.96-3

 

libaio-devel-0.3.96-3

 

Packages Red Hat Enterprise Linux 4.0

binutils-2.15.92.0.2-10.EL4

 

compat-db-4.1.25-9

 

control-center-2.8.0-12

 

gcc-3.4.3-9.EL4

 

gcc-c++-3.4.3-9.EL4

 

glibc-2.3.4-2

 

glibc-common-2.3.4-2

 

gnome-libs-1.4.1.2.90-44.1

 

libstdc++-3.4.3-9.EL4

 

libstdc++-devel-3.4.3-9.EL4

 

make-3.80-5

 

Packages SUSE Linux Enterprise Server 9

gcc-3.3.3

 

gcc-c++-3.3.3

 

glibc-2.3.3

 

libaio-0.3.102-1.2ia64

 

libaio-devel-0.3.102-1.2ia64

 

make-3.80

 

PL/SQL native compilation, Pro*C/C++, Oracle Call Interface, Oracle C++ Call Interface, Oracle XML Developer's Kit (XDK)

Intel C++ Compiler 8.1 or later and the version of GNU C and C++ compilers listed previously for the distribution are supported for use with these products.

Note: Intel C++ Compiler v8.1 or later is supported. However, it is not required for installation. On Red Hat Enterprise Linux 3, OCCI is supported with version 3.2 of the GNU C++ compiler. This is the default compiler version. OCCI is also supported with Intel Compiler v8.1 with gcc 3.2.3 standard template libraries.

Oracle XML Developer's Kit is not supported with GCC on Red Hat Linux 4.0. It is supported only with Intel C++ Compiler (ICC).

On Red Hat Enterprise Linux 4.0, Oracle C++ Call Interface (OCCI) does not support GCC 3.4.3. To use OCCI on Red HatEnterprise Linux 4.0, you must install GCC 3.2.3.

Oracle JDBC/OCI Drivers

You can use the following optional JDK version with the Oracle JDBC/OCI drivers; however, it is not required for the installation:

JDK 1.4.2 with the JNDI extension

Note: JDK 1.4.2 is installed with this release.

Oracle Real Application Clusters

For a cluster file system, use one of the following options:

Oracle Cluster File System (OCFS)

Version 1.0.13-1 or later for SUSE Linux Enterprise Server 8 on Itanium systems

Version 1.0.11-1 or later for other installations

OCFS requires the following kernel packages:

ocfs-support

 

ocfs-tools

 

ocfs-kernel_version

In the preceding list, the variable kernel_version represents the kernel version of the operating system on which you are installing OCFS.

Note: OCFS is required only if you want to use a cluster file system for database file storage. If you want to use Automatic Storage Management or raw devices for database file storage, then you do not need to install OCFS.

Obtain OCFS kernel packages, installation instructions, and additional information about OCFS from the following URL:

Oracle Cluster File System 2 (OCFS2)

For information about Oracle Cluster File System version 2, refer to the following Web site:

For OCFS2 certification status, refer to the Certify page on OracleMetaLink.

In addition, if you want to use the support library for Automatic Storage Management (ASMLIB), then install the following ASMLIB kernel package for your distribution:

Red Hat Enterprise Linux 3.0:

oracleasm 2.4.21-27.EL-1.0.4-2.ia64.rpm

 

Red Hat Enterprise Linux 4.0:

oracleasm 2.6.9-11.EL-2.0.0-1.ia64.rpm

 

Obtain ASMLIB kernel packages from the following URL:

 

3.4   Software Requirements List for Linux on POWER

Table 2-4 Linux on POWER System Requirements

Item

Requirement

Operating Systems Linux on POWER

Red Hat Enterprise Linux AS/ES 4 (Update 1 or later)

SUSE Linux Enterprise Server 9 (Service Pack 2 or later)

Kernel version Linux on Power

Red Hat Enterprise Linux 4 (Update 1):

2.6.9-11.EL

SUSE Linux Enterprise Server 9:

Linux 2.6.5-7.191-pseries64

Packages Red Hat Enterprise Linux 4

Gmake-3.80-5

 

gcc-3.4.3-22.1

 

gcc-ppc32-3.4.3-22.1

 

gcc-c++-3.4.3-22.1

 

gcc-c++-ppc32-3.4.3-22.1

 

glibc-2.3.4-2.9

 

glibc-2.3.4-29 (64-Bit)

 

libgcc-3.4.3-9.EL4

 

libgcc-3.4.3-9.EL4.ppc64.rp

 

libstdc++-3.4.3-9.EL4

 

libstdc++-devel-3.4.3-9.EL4

 

libaio-0.3.103-3

 

libaio-0.3.103-3 (64-Bit)

 

libaio-devel-0.3.103-3 (64-Bit)

 

compat-libstdc++-33-3.2.3-47.3

binutils-2.15.92.0.2-13

 

Packages SUSE Linux Enterprise Server 9:

gcc-3.3.3-43.34

 

gcc-64bit-9-200505240008

 

gcc-c++-3.3.3-43.34

 

glibc-2.3.3-98.47

 

glibc-64bit-9-200506062240

 

libgcc-3.3.3-43.34

 

libgcc (64-bit) 9-200505240008

 

libstdc++-3.3.3-43.34

 

libstdc++-devel-3.3.3-43.34

 

libaio-0.3.102-1.2

 

libaio-64bit-9-200502241152

 

libaio-devel-0.3.102-1.2

 

libaio-devel-0.3.102-1.2 (64-bit)

 

Gmake-3.80-184.1

binutils-2.15.90.0.1.1-32.10

binutils-64bit-9-200505240008

 

C/C++ Runtime Environment

Download the IBM XL C/C++ Advanced Edition V7.0.1 for Linux Runtime Environment Component for free without any license requirement from the following link:

 

You must also download and install the XL Optimization Libraries component from this link.

PL/SQL native compilation, Pro*C/C++, Oracle Call Interface, Oracle C++ Call Interface, Oracle XML Developer's Kit (XDK)

The version of C and C++ compilers listed previously for your distribution is supported for use with these products

Note: IBM XL C/C++ compiler version 7.0 or later is also supported.

If the IBM XL C/C++ Advanced Edition V7.0.1 for Linux on POWER compiler is to be used for Oracle user applications, then the required version is V7.0.1 or higher. For download information and updates, refer to the following link:

 

If the IBM XL C/C++ Advanced Edition V7.0.1 for Linux on POWER compiler is installed, then the IBM XL C/C++ Advanced Edition V7.0.1 for Linux Runtime Environment Component is installed automatically.

Pro*COBOL

The following products are certified for use with Pro*COBOL:

Micro Focus Server Express 4.0 SP 2 (for SLES 9)

Pro*FORTRAN

XL Fortran Advanced Edition V9.1.1 (or later) for Linux

Oracle JDBC/OCI Drivers

You can use the following optional JDK versions with the Oracle JDBC/OCI drivers; however, they are not required for the installation:

IBM Java 1.4.2 64-bit (SR1a) or later

IBM Java 1.4.2 32-bit (SR1a) or later

IBM Java 1.3.1 32-bit (SR8) or later (for SLES 9 only)

Note: By default, JDK 1.4.2 32-bit is installed with this release.

Oracle Real Application Clusters

IBM General Parallel File System (GPFS), version 2.3.0.6

 

3.5   Software Requirements list for IBM zSeries Based Linux

Table 2-5 IBM zSeries Based Linux System Requirements

Item

Requirement

Operating systems

Red Hat Enterprise Linux 4 (Update 2 or later)

SUSE Linux Enterprise Server (SLES) 9 (Service Pack 2 or later)

Kernel version

The system must be running the following kernel version (or a later version) for each Linux distribution.

Red Hat Enterprise Linux 4. 0 (Update 2 or later):

2.6.9-22.EL

SUSE Linux Enterprise Server 9 (SP2 or later):

2.6.5-139

Packages

The following packages (or later versions) must be installed:

Red Hat Enterprise 4.0:

gcc-3.4.4-2

 

gcc-c++-3.4.4-2

 

libgcc-3.4.4-2

 

libstdc++-devel-3.4.4-2

 

compat-libgcc-295-2.95.3-81

 

compat-libstdc++-33-3.2.3-47.3

 

glibc-2.3.4-2.13

 

libaio-0.3.103-3

 

libaio-devel-0.3.103-3

 

libstdc++-devel 3.4.4-2

SUSE Linux Enterprise Server 9:

gcc-3.3.3-43.34

 

gcc-c++-3.3.3-43.34

 

glibc-2.3.3-98.47

 

glibc-2.3.3-98.28 (64-bit)

 

libgcc-3.3.3-43.34

 

libgcc (64 bit) unknown

 

libstdc++-3.3.3-43.34

 

libstdc++-devel-3.3.3-43.34

 

libaio-0.3.102-1.2

 

libaio-0.3.98-18.3 (64-bit)

 

libaio-devel-0.3.102-1.2

 

libaio-devel-0.3.98-18.3 (64-bit)

 

Gmake-3.80-184.1

Pro*COBOL

The following products are certified for use with Pro*COBOL:

Red Hat Enterprise 4.0:

AcuCobol 6.2

SUSE Linux Enterprise Server 9:

Microfocus Server Express 4.0 SP 2

Oracle JDBC/OCI Drivers

You can use the following optional JDK versions with the Oracle JDBC/OCI drivers; however, they are not required for the installation:

IBM SDK 1.5 or later

IBM SDK1.4.2 (64-bit)

IBM SDK 1.3.1 (31-bit)

IBM SDK 1.4.2 (31-bit)

Note: By default, JDK 1.4.2 31-bit is installed with this release.

Pro*COBOL

The following products are certified for use with Pro*COBOL:

Red Hat Enterprise 4.0: AcuCobol 6.

SUSE Linux Enterprise Server 9: Microfocus Server Express 4.0 SP 2

 

转载自: https://www.cnblogs.com/lhrbest/p/6402549.html#BABBHJEA




来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/31519308/viewspace-2717410/,如需转载,请注明出处,否则将追究法律责任。

上一篇: Oracle 11GR2 DG部署
请登录后发表评论 登录
全部评论

注册时间:2018-01-30

  • 博文量
    19
  • 访问量
    7696