ITPub博客

首页 > 数据库 > Oracle > 【Oracle】windows 安装Oracle 10g 报错,实际为 6.1未通过

【Oracle】windows 安装Oracle 10g 报错,实际为 6.1未通过

原创 Oracle 作者:dmcatding 时间:2016-12-07 15:52:26 1 删除 编辑
软件参数:
系统:Windows 7 旗舰版
数据库:Oracle 10g 102010_win64_x64_database

问题描述
 安装Oracle10g提示不能安装,如图:


查看Log信息如下:
正在检查安装程序要求...

检查操作系统版本: 必须是5.1 or 5.2。    实际为 6.1
                                      未通过 <<<<
正在退出 Oracle Universal Installer。您可以在 C:\Program Files\Oracle\Inventory\logs\installActions2016-12-07_03-26-09PM.log 中找到本次会话的日志
请按 Enter 键退出...

解决方案:
X:xxxxx\database\install目录下编辑 oraparam.ini 

[Certified Versions]
#You can customise error message shown for failure, provide value for CERTIFIED_VERSION_FAILURE_MESSAGE
Windows=5.1,5.2,6.1

#[Windows-4.0-required]
#Minimum display colours for OUI to run
MIN_DISPLAY_COLORS=256
#Minimum CPU speed required for OUI

保存退出。重新 执行database 目录下setup.exe 已右键 管理员身份运行 弹出下图成功!



如果失败,继续第二种方法:

win7 旗舰版下安装oracle10g 不兼容问题

windows7安装oracle 10g安装过程及注意事项。
1.因为oracle 10g暂时没有与win7兼容的版本,我们可以通过对安装软件中某些文件的修改达到安装的目地。
a)打开“\Oracle 10G \stage\prereq\db”路径,找到refhost.xml文件,打开,向其中添加如下代码并保存。
<OPERATING_SYSTEM>
             <VERSION VALUE="6.1"/>
</OPERATING_SYSTEM>
b)打开“\Oracle 10G \install”路径,找到oraparam.ini文件,打开,向其中添加如下代码并保存。
[Windows-6.1-required]
#Minimum display colours for OUI to run
MIN_DISPLAY_COLORS=256
#Minimum CPU speed required for OUI
#CPU=300
[Windows-6.1-optional]
2.找到oracle安装文件中的setup应用程序,右击,打开“兼容性疑难解答”,点击“尝试建议的设置”,选择“启动程序”。
3.继续上一步的安装,安装oracle 10g,直到安装程序结束。
4.根据以上几步的安装,oracle很可能无法正常使用,最起码在我安装结束后,我的sqlplus无法正常使用,这种情况就涉及到权限的问题。具体可通过以下措施解决:
a)打开你已经安装好的oracle程序的路径“\oracle\product\10.2.0\db_1\BIN”,点击sqlplus.exe应用程序,右击—属性,选择兼容性,点击“以兼容模式运行这个程序”单选框,选择“window xp(service pack3)”,继续点击“以管理员身份运行此程序”单选框,最后点击应用-确定。
b)如此sqlplus就可以正常使用了。
5.对于一些需要远程访问数据库的用户,如此配置还会遇到Net Configuration Assistant无法启动的情况,这就需要找到“\oracle\product\10.2.0\db_1\BIN”路径下的launch.exe应用程序,具体配置如上4。
6.综合以上的配置,oracle 10g数据库就可以正常使用了。
7.对于数据库开发人员来说,有时候需要借助数据库工具对数据库进行操作,比如利用plsql developer工具操作数据库。如果利用以上oracle的安装配置,可能无法正常使用plsql developer,这涉及权限的问题,可以给“plsqldev.exe”应用程序设定兼容性和权限。具体操作,如上4。

安装ORALCE还是装在比较稳定的系统里
以前做测试时也在WIN7下装过Oracle 10g
即使根据网上资料装上成功了 一些功能还是不好用
或者是连接Oracle不稳定 时连时断
项目出问题 好多时候不能确定是 ORACLE 还是程序 问题。
特别是软件开发的数据库 还是装在XP,linux 等经过检验过的稳定的系统。

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/30327022/viewspace-2129981/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论

注册时间:2015-07-04

  • 博文量
    48
  • 访问量
    49333