ITPub博客

首页 > Linux操作系统 > Linux操作系统 > Tips--因EXP和DB component的版本不一致而exp出错

Tips--因EXP和DB component的版本不一致而exp出错

原创 Linux操作系统 作者:vongates 时间:2019-02-28 08:09:05 0 删除 编辑

在一台用于恢复测试的服务器上对一个刚恢复完的DB做结构的export备份。以备不时之需。写好一个parfile后做exp出现ORA-924的错,看到它很熟悉,就是因为exp的版本和DB数据字典中的版本不一致所致的。确认一下我的想法是对的。


[oracle@szvsx019:/oradata]
[sam]~$ cat samexp.par
userid=system/password
owner=SAM
file=sam.dump
log=sam.exp
direct=y
rows=N


[oracle@szvsx019:/oradata]
[sam]~$ exp parfile=samexp.par

Export: Release 9.2.0.6.0 - Production on Sat Jul 15 06:52:46 2006

Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.


Connected to: Oracle9i Enterprise Edition Release 9.2.0.6.0 - 64bit Production
JServer Release 9.2.0.6.0 - Production
Export done in US7ASCII character set and AL16UTF16 NCHAR character set
server uses UTF8 character set (possible charset conversion)
Note: table data (rows) will not be exported

About to export specified users ...
. exporting pre-schema procedural objects and actions
. exporting foreign function library names for user SAM
. exporting PUBLIC type synonyms
. exporting private type synonyms
. exporting object type definitions for user SAM
EXP-00008: ORACLE error 942 encountered
ORA-00942: table or view does not exist
EXP-00024: Export views not installed, please notify your DBA
EXP-00000: Export terminated unsuccessfully
[oracle@szvsx019:/oradata]
[sam]~$ sqlplus /nolog

SQL*Plus: Release 9.2.0.6.0 - Production on Sat Jul 15 06:53:39 2006

Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.

SQL> conn / as sysdba
Connected.
SQL> select * from v$version;

BANNER
----------------------------------------------------------------
Oracle9i Enterprise Edition Release 9.2.0.6.0 - 64bit Production
PL/SQL Release 9.2.0.6.0 - Production
CORE 9.2.0.6.0 Production
TNS for HPUX: Version 9.2.0.6.0 - Production
NLSRTL Version 9.2.0.6.0 - Production

SQL> select comp_id,version,status from dba_registry;

COMP_ID VERSION STATUS
------------------------------ ------------------------------ -----------
CATALOG 9.2.0.1.0 VALID
CATPROC 9.2.0.1.0 VALID

SQL>

1、 imp工具的版本应该和目标数据库的版本一致;
2、 exp工具的版本应该与源数据库和目标数据库中版本最低的一个相一致;

版本的对比可以看这里 http://vongates.itpub.net/post/2553/35118

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/29987/viewspace-51962/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论

注册时间:2018-09-11

  • 博文量
    449
  • 访问量
    292658