ITPub博客

首页 > Linux操作系统 > Linux操作系统 > Eclipse中版本管理工具的配置

Eclipse中版本管理工具的配置

原创 Linux操作系统 作者:lastwinner 时间:2008-01-23 21:37:29 0 删除 编辑

        单位机器上,原先在A网段,CVS2.0.51在p1机器上配置后可以正常使用,转到B网段后,在服务器p2上设置,却死活都不行,在自己机器p3上也一样 都是xp sp2, 都是用的Eclipse的核心功能去访问的,为什么不行呢? 2.0.51, 2.0.58d, 2.5.03.2382, 2.5.03.2704....... 试了一堆的版本,都不行,郁闷

        具体是这样的:客户端在创建CVS Repository的时候,出错信息为: socket exception: connection reset。网上找了好多资料,都无法解决问题。

        官方文档中指导,在pserver连接方式下,可使用telnet 2401,然后随便键入点文字,回车,如果有报出 cvs [authserver aborted]: bad auth protocol start: <你随便输入的文字>,说明cvs运行正常。具体请参阅官方文档。可我在运行此命令后,随便敲一个键,telnet就退出了,屏幕一闪,啥都看不到。

        最后实在没招了,弄了一个SVN,嘿嘿,这下好用了。SVN功能比CVS强大很多,在对二进制文件的处理算法上也有优点,就用它吧!具体配置可在网上查找,我这里就不罗嗦了。

         回家自己机器上,也是xp sp2,配置完成后(CVSNT 2.5.03.2382),完全可以正常访问(碰到一点小问题,报告no such repository,把C:\test改为 /test 即可),这下更深刻的怀疑单位那里不能用是因为网络问题了。

         总结:1、也许是网络问题导致CVSNT未配置成功
                     2、SVN比CVS强大,是Subversion管理中的佼佼者,被视为CVS的取代者
                     3、不在一颗树上吊死,怎么也得多找几棵树,就算最后还是吊死,那最起码也死而不憾了

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/29867/viewspace-158539/,如需转载,请注明出处,否则将追究法律责任。

上一篇: 没有了~
请登录后发表评论 登录
全部评论

注册时间:2007-12-12

  • 博文量
    223
  • 访问量
    2806450