ITPub博客

首页 > 数字化转型 > ERP > Confluence Office 连接器的需求

Confluence Office 连接器的需求

ERP 作者:OSSEZTEC 时间:2014-03-19 06:43:44 0 删除 编辑

这个页面描述了你希望 使用 Office 连接器 需要的软件以及配置。


你的站点系统管理员可以完全启用或者禁用 Office 连接器,或者只启用或者禁用一部分。Office 连接器的选项在你的 Confluence 页面中可能显示的结果也不同,这个与你使用的站点有关,也与站点的主题和配置都有关系。

请参考 Confluence 管理员指南中有关 配置 Office 连接器的章节中的有关内容,如果您对使用这个功能有什么问题,请询问你的系统管理员。


总体需求


  • 请确认你的 Confluence 服务器运行在 Java 5(JDK 1.5)及其以上版本。
  • WebDAV plugin 插件必须被启用,这是因为 Office 连接器使用 WebDAV 与 Office 文档进行数据传输。注意,WebDAV 是随着 Confluence 一同安装的,WebDAV 可以被系统管理器用或者禁用。如果需要的话,请参考启用插件和配置 WebDAV  选项中有关的说明。
  • 请确认你 Confluence 服务器的 base URL 是正确的。在 Confluence 的管理员界面中单击 基本配置(General Configuration),找到有关服务器 Base URL 的配置信息。当用户在 Confluence 页面中编辑了 Office 文档,然后保存上传的时候,Confluence 使用这个 URL 地址来确定上传的文档保存在服务器的什么位置。如果这个 URL 文件没有被正确配置的话,你上传的文档可能被保存到其他服务器上了。

 

 

 


在 Confluence 页面中查看 Office 和 PDF 文件的需求

如果你希望使用 查看文件(View File)宏 或者 在 Confluence 中显示 Office 文件 页面总显示的添加到 Wiki 中的附件。你需要设置下面的一些软件。

浏览器和 Flash 播放器

如果你在 Wiki 页面中使用浏览器来查看 Office 文件,你需要 Adobe Flash Player 才能进行查看。Adobe Flash Player 的版本最低要 9 或者其他更高的版本。你不需要在你的本地计算机中安装 Office 组件也可以查看页面中的 Office 文档。

文件类型

Confluence 可以显示的文件类型兼容 Microsoft Office 97-2007 和 PDF 文件。下面列表为可以被支持的文件类型:

  • .doc 和 .docx
  • .xls 和 .xlsx
  • .ppt 和 .pptx
  • .pdf


在 Confluence 页面中导入 Word 文档的需求

 

  • 导入的文档可以是 Microsoft Word 文档,文档的类型是 .doc 和 .docx。这些文档必须为有效的 Word 97-2007 格式文档。

 

 


在 Confluence 页面中直接编辑 Office 文件的需求

Office 编辑器运行你对嵌入到 Confluence Wiki 页面中的文档进行直接编辑或者从页面附件视图中进行编辑。

你必须按照下面的步骤进行设置来保证你的文档编辑功能能够正常使用。

浏览器
  • 如果你使用的是 FireFox,你需要按照 FireFox 的插件。当插件第一需要使用的时候,Firefox 将会提示进行插件安装。你可以从下面页面中 为 Office 连接器安装 FireFox 插件 找到有关插件安装的相关内容。
  • 注意:不支持 Chrome 浏览器。Chrome 浏览器是不只是 WEBDAV 客户端的,所以有关 Office 组件的所有功能是不能在 Chrome 浏览器上使用的。请参考 CONF-23322 获得有关这个问题的详细信息。
Office 编辑器

希望编辑 Office 文件,你需要在你的本地安装 Microsoft Office 或者 OpenOffice (请参考下面的配置图)。

  • 如果你使用的是 Firefox 浏览器,你可以在上面的 2 个编辑器中随意选择。Firefox 将会允许你配置某种类型的文件使用何种编辑器进行打开编辑。请参考页面  为 Office 连接器安装 FireFox 插件 中的相关内容。
  • 如果你使用的是 IE (Internet Explorer)浏览器,你需要安装 Microsoft Office。在 IE 浏览器中你不能在 OpenOffice 中编辑 Office 文件。
配置图

你需要下面的软件组合才能让在 Confluence 页面中直接编辑 Office 文件功能正常使用。

操作系统平台

Office 版本

浏览器

  • Windows 7,
  • Windows Vista, or
  • Windows XP 使用更新 2 或者 3
  • OpenOffice 2.x – 3.x, 或者
  • Microsoft Office XP, 2003, 2007 或者 2010
  • Internet Explorer 8.x – 9.x, or
  • Firefox – 最新版本
  • Mac OS X 10.5 和 10.6
  • OpenOffice 2.x – 3.x
  • 在 Word 中编辑的特性,已经确定能够在 OpenOffice 3.2.0 下工作。
  • Firefox – 最新版本
  • Linux
  • OpenOffice 2.x – 3.x 
    在 Linux 平台下唯一能正常工作的 Office 软件为 OpenOffice。一般来说任何 WebDAV 应用都能正常工作的。
  • Firefox – 最新版本
Icon

微软已经决定正式停止 Windows XP 操作系统的更新。如果可能的话,请升级到其他操作系统版本。

因此,在 2014 年 4 月 8 日之后,我们不再提供 Windows XP 技术帮助,包括帮助保护你的电脑的自动更新。 Microsoft 还将在此日期之后停止为 Windows XP 提供 Microsoft Security Essentials 下载服务。 (如果你已经安装 Microsoft Security Essentials,你将在一段有限时间内继续收到反恶意软件签名更新,但这并不表明你的电脑安全可靠,因为 Microsoft 将不再提供用于保护你的电脑的安全更新。)

请参考微软的支持链接:http://windows.microsoft.com/zh-cn/windows/end-support-help

 

 


来源:http://cwiki.ossez.com/pages/viewpage.action?pageId=2393412

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/29468687/viewspace-1124561/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论

注册时间:2014-02-02

  • 博文量
    136
  • 访问量
    207634