ITPub博客

首页 > 数据库 > Oracle > ./runInstaller Could not execute auto check for display colors

./runInstaller Could not execute auto check for display colors

原创 Oracle 作者:jieyu119 时间:2018-02-24 16:24:13 0 删除 编辑
1. Oracle软件安装, 运行./runInstaller 报错
Checking monitor: must be configured to display at least 256 colors
   >>> Could not execute auto check for display colors using command /usr/bin/xdpyinfo. Check if the DISPLAY variable is set.    Failed <<<< 


2.查询MOS,根据提供的4种解决方法, 使用了a方法,安装缺失的RPM包,异常解决.

如下为MOS(11.2:./RUNINSTALLER results in: Could not execute auto check for display colors using command /usr/bin/xdpyinfo (Doc ID 888699.1))给的解决方法.


a.  Install the missing RPM

xorg-x11-utils-.x86_64.rpm

For REDHAT/OEL 6 also install

xorg-x11-xauth-.x86_64.rpm

b. Confirm the xdpyinfo utility now exists with the following permissions:

ls -la /usr/bin/xdpyinfo

We should be seeing the following permissions:

-rwxr-xr-x 1 root root 37192 Jul 19  2006 /usr/bin/xdpyinfo*

c. logout and login again as the user who is attempting the install to generate the file  .Xauthority

d. Try the install again


2.1. 安装xorg-x11-utils.x86_64 rpm包

[root@11GR2-test ~]# yum -y install xorg-x11-utils*
Loaded plugins: refresh-packagekit, security, ulninfo
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package xorg-x11-utils.x86_64 0:7.5-14.el6 will be installed
--> Processing Dependency: libdmx.so.1()(64bit) for package: xorg-x11-utils-7.5-14.el6.x86_64
--> Processing Dependency: libXxf86dga.so.1()(64bit) for package: xorg-x11-utils-7.5-14.el6.x86_64
--> Running transaction check
---> Package libXxf86dga.x86_64 0:1.1.4-2.1.el6 will be installed
---> Package libdmx.x86_64 0:1.1.3-3.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved


============================================================================
 Package                Arch              Version                  Repository                       Size
============================================================================
Installing:
 xorg-x11-utils         x86_64         7.5-14.el6     public_ol6_latest                           100 k
Installing for dependencies:
libXxf86dga            x86_64        1.1.4-2.1.el6                  public_ol6_latest                  17 k
 libdmx                  x86_64            1.1.3-3.el6                  public_ol6_latest                      14 k


Transaction Summary
============================================================================
Install       3 Package(s)

Total download size: 132 k
Installed size: 270 k
Downloading Packages:

Total                                                           870 kB/s | 132 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : libXxf86dga-1.1.4-2.1.el6.x86_64           1/3 
  Installing : libdmx-1.1.3-3.el6.x86_64                   2/3 
  Installing : xorg-x11-utils-7.5-14.el6.x86_64            3/3 
  Verifying  : libdmx-1.1.3-3.el6.x86_64                      1/3 
  Verifying  : xorg-x11-utils-7.5-14.el6.x86_64           2/3 
  Verifying  : libXxf86dga-1.1.4-2.1.el6.x86_64          3/3 

Installed:
  xorg-x11-utils.x86_64 0:7.5-14.el6                                                                                                                                   
Dependency Installed:
  libXxf86dga.x86_64 0:1.1.4-2.1.el6                                                    libdmx.x86_64 0:1.1.3-3.el6                                                   
Complete!


3. 重新运行./runInstaller安装oracle软件

[oracle@11GR2-test ~]$ export DISPLAY=192.168.181.128:1.0
[oracle@11GR2-test ~]$ xhost +
access control disabled, clients can connect from any host
[oracle@11GR2-test ~]$ 
[oracle@11GR2-test ~]$ cd /u01/packages/
[oracle@11GR2-test database]$ ./runInstaller 
可以安装.


来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/28569596/viewspace-2151216/,如需转载,请注明出处,否则将追究法律责任。

下一篇: 没有了~
请登录后发表评论 登录
全部评论

注册时间:2013-04-12

  • 博文量
    30
  • 访问量
    157674