ITPub博客

glibc解决“libc.so.6: version GLIBC_2.14 not found”报错问题

原创 Linux操作系统 作者:kunlunzhiying 时间:2018-05-11 15:03:44 0 删除 编辑
1 、 strings /lib64/libc.so.6 |grep GLIBC_

2、下载软件并升级
# wget http://ftp.gnu.org/gnu/glibc/glibc-2.14.tar.gz 
# wget http://ftp.gnu.org/gnu/glibc/glibc-ports-2.14.tar.gz 
# tar -xvf  glibc-2.14.tar.gz 
# tar -xvf  glibc-ports-2.14.tar.gz
# mv glibc-ports-2.14 glibc-2.14/ports
# mkdir glibc-build-2.14
# cd glibc-build-2.14/ 
# ../glibc-2.14/configure  --prefix=/usr --disable-profile --enable-add-ons --with-headers=/usr/include --with-binutils=/usr/bin
# make


3、#  make install

4、再次查看glibc支持的版本
可以看到glibc支持的版本已经到2.14,再次执行程序就不会报错了

5、ldconfig  在删除glibc库后的紧急恢复

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/28211342/viewspace-2154341/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论

注册时间:2014-07-28

  • 博文量
    669
  • 访问量
    234736