ITPub博客

首页 > Linux操作系统 > Linux操作系统 > Centos下安装oracle11g 出现njni11错误

Centos下安装oracle11g 出现njni11错误

原创 Linux操作系统 作者:bug小辉 时间:2013-08-22 09:34:02 0 删除 编辑
今天,又在虚拟机上安了一次oracle 11g。不过这次没有按照官方文档中要求去安装需要的程序包。而是直接cd到/media/cdrom/CentOS/RPMS下选择全部安装。结果发现还是少一些安装包。这个在安装oracle软件的时候没有报错。而是在配置监听和创建数据库的时候出现以下错误:
然后在网上各种搜索!无意中看到某位大神说缺少以下依赖包:libaio和libaio-dev。
于是,到CentOS/RPMS先寻找。果然有这两个包:libaio-0.3.105-2.i386.rpm和libaio-devel-0.3.105-2.i386.rpm。然后安装之。
然后再执行netca。OK!成功。dbca也没有问题。
这个可能只是一个特例,也许缺少其他包也会报这个错误。所以还是按照官方文档提供的依赖包逐个安装比较好点。

netca.jpg

rpm.jpg

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/27129040/viewspace-769010/,如需转载,请注明出处,否则将追究法律责任。

下一篇: 没有了~
请登录后发表评论 登录
全部评论

注册时间:2012-07-04

  • 博文量
    3
  • 访问量
    14884