ITPub博客

首页 > 应用开发 > IT综合 > IIS 中没有发现ASP.NET v4.0

IIS 中没有发现ASP.NET v4.0

IT综合 作者:perfychi 时间:2014-04-10 18:00:49 0 删除 编辑
http://blog.csdn.net/miehuo/article/details/12850103

【问题描述】:在给服务器打.NET Framewrok 4.0框架的补丁时,发现该类库已经被安装,但是IIS的应用程序池中却并未能显示,只能在新建应用程序池时选择。

【原因】:可能在安装.NET Framewrok 4.0之前,IIS就已经装好了,结果在IIS的应用程序池中只有.NET 2.0的Classic .NET AppPool和DefaultAppPool。在使用vs2010开发的程序时,由于使用的是.NET Framework 4.0,所以部署到IIS上的时候,页面提示“无法识别的属性targetFramework"错误。

【解决办法】:只需要重新安装一下就可以了.在Frameworv4.0的目录中安装的程序以管理员权限新运行一下就可以了,在运行框中执行以下命令:

%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe -i

IIS的应用程序池中就会多出2项来,然后再在服务器下打开控制面板--管理工具--Internet 信息服务(IIS)管理器,选择默认网站,在右边的“管理网站”栏里选择“高级设置…”,将“应用程序池”修改为“ASP.NET v4.0 ”,如下图所示:

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/27042095/viewspace-1139676/,如需转载,请注明出处,否则将追究法律责任。

上一篇: undo使用率
请登录后发表评论 登录
全部评论

注册时间:2012-06-06

  • 博文量
    486
  • 访问量
    2720158