ITPub博客

首页 > 应用开发 > Python > 如何修改 CentOS 6.x 上默认Python 版本

如何修改 CentOS 6.x 上默认Python 版本

原创 Python 作者:lhrbest 时间:2019-09-04 08:46:02 0 删除 编辑


如何修改 CentOS 6.x 上默认Python 版本


http://blog.itpub.net/26736162/viewspace-2564409/


CentOS 6.x 上的 Python 版本是 2.6.x 的,而  CentOS 7.x 上的 Python 版本是 2.7.x 的,这意味着我要实现的功能要适配这两种版本的系统。

你可能会说,这有什么的,自己写的时候,注意一下就好了。

事情其实没有那么容易,我要实现的功能是基于一个框架进行定制,需要修改不少的框架代码。这个框架在不同的 Linux 版本上,有不同的版本,而且差异巨大,曾经想过在 CentOS 6.x 和 CentOS 7.x 将这个框架安装成同一个版本,最后还是失败了,无法安装,原因就是高版本需要 Python2.7,而 CentOS 6.x 上只有 Python2.6。

这个历史问题一直遗留到现在,由于这次的功能影响到的代码较多,如果要对两个版本的框架分别进行定制的话,需要花不少的时间,为了不维护两套版本,避免浪费多余的精力去做适配,我决定将 CentOS 6.x 上默认的 Python2.6 升级成 Python2.7,这样就一劳永逸了。

下面是整个升级过程,别看步骤简单,这些精简步骤的背后可是有不少的坑,被我踩过后,你可以直接使用了。

1、首先确认下你机器上的默认的 Python 版本

$ python -VPython 2.6.6$ whereis pythonpython: /usr/bin/python /usr/bin/python2.6 /usr/lib/python2.6 /usr/lib64/python2.6 /usr/local/bin/python /usr/include/python2.6 /usr/share/man/man1/python.1.gz

2、由于我们将使用编译安装的方式,所以要安装下 gcc,及一些工具包。

注意一定要全部安装,不然后面会发现有不少 python 的工具用不了。

比如不安装 zlib 会无法安装 setuptools,不装 openssl 和 openssl-devel,会无法使用 pip 工具等

$ yum install gcc -y$ yum groupinstall "Development tools"$ yum install zlib-devel bzip2-devel openssl openssl-devel ncurses-devel sqlite-devel -y

如果你这里未按照我的步骤来安装,你后面使用的时候出现了各种各样的问题,不要慌,只要再回来这里,把没安装的包装上,安装完成后,你需要进入第四步重新编译安装Python。

3、下载最新的 Python2.7.x 安装包,解压并进入指定目录

$ wget https://www.python.org/ftp/python/2.7.14/Python-2.7.14.tgz$ tar zxvf Python-2.7.14.tgz$ cd Python-2.7.14

4、配置,编译,安装

# --prefix  指定 python 安装的路径$ ./configure --prefix=/usr/local/python/python2.7$ make$ make install

./configure 命令执行完毕之后创建一个文件creating Makefile,供下面的make命令使用 执行  make install 之后就会把程序安装到我们指定的目录中去。

Configure是一个可执行脚本,它有很多选项,在待安装的源码路径下使用命令./configure –help输出详细的选项列表。其中  --prefix 选项是配置安装的路径,如果不配置该选项,安装后可执行文件默认放在/usr /local/bin,库文件默认放在  /usr/local/lib ,配置文件默认放在  /usr/local/etc ,其它的资源文件放在  /usr /local/share。如果配置  --prefix,如: ./configure --prefix=/usr/local/test 可以把所有资源文件放在/usr/local/test的路径中,不会杂乱。

用了  --prefix 选项的另一个好处是卸载软件或移植软件。当某个安装的软件不再需要时,只须简单的删除该安装目录,就可以把软件卸载得干干净净;移植软件只需拷贝整个目录到另外一个机器即可(相同的操作系统)。当然要卸载程序,也可以在原来的make目录下用一次  make uninstall,但前提是make文件指定过uninstall。

5、查看此时系统的Python版本

$ python -VPython 2.6.6

如果你查看还是 Python 2.6.6 版本,请继续看第六步。

6、修改系统默认的 Python 版本

查看新安装的Python版本,当前系统的Python版本,并将系统指向的Python从2.6.x修改为2.7.x,再次查看当前系统的Python版本,已经变更为2.7.x

# 这是我们刚安装的 Python$/usr/local/bin/python2.7 -VPython 2.7.14# 这是系统默认 Python$ /usr/bin/python -V Python 2.6.6# 备份原来的 Python 文件$ mv /usr/bin/python /usr/bin/python.bak# 建立软链接,将我们刚安装的 python2.7 做为系统默认版本ln -s /usr/local/bin/python2.7 /usr/bin/python# 再次查看 Python 版本,已经成功切换过来$ python -VPython 2.7.14

7、重新指定 yum 的Python版本

上面我们改了系统的默认 Python 版本,由于CentOS 6.x 的  yum 是基于Python2.6 的,为了不影响 yum 的使用,需单独将yum指向python2.6版本。

编辑:vim /usr/bin/yum

/usr/bin/python 改成  /usr/bin/python2.6

#!/usr/bin/python2.6

8、安装 setuptools 及 pip

pip是python的安装工具,很多python的常用工具,都可以通过pip进行安装。要安装pip,首先要安装setuptools。从这个链接,你可以得到相关信息: https://pypi.python.org/pypi/setuptools

# 下载 setuptools$ wget https://pypi.python.org/packages/ff/d4/209f4939c49e31f5524fa0027bf1c8ec3107abaf7c61fdaad704a648c281/setuptools-21.0.0.tar.gz#md5=81964fdb89534118707742e6d1a1ddb4

同样的,进行安装:

$ tar vxf setuptools-21.0.0.tar.gz $ cd setuptools-21.0.0$ python setup.py  install

安装完成后,下载pip。其信息在如下网站: https://pypi.python.org/pypi/pip

# 下载 pipwget https://pypi.python.org/packages/41/27/9a8d24e1b55bd8c85e4d022da2922cb206f183e2d18fee4e320c9547e751/pip-8.1.1.tar.gz#md5=6b86f11841e89c8241d689956ba99ed7

同样的,进行安装

$ tar vxf pip-8.1.1.tar.gz $ cd pip-8.1.1$ python setup.py install

安装完成后,执行  pip list 查看一下安装的包,或者也可以试着安装一下第三方包  pip install requests 看是否使用正常。






About Me

........................................................................................................................

● 本文作者:小麦苗,部分内容整理自网络,若有侵权请联系小麦苗删除

● 本文在itpub、博客园、CSDN和个人微 信公众号( xiaomaimiaolhr)上有同步更新

● 本文itpub地址: http://blog.itpub.net/26736162

● 本文博客园地址: http://www.cnblogs.com/lhrbest

● 本文CSDN地址: https://blog.csdn.net/lihuarongaini

● 本文pdf版、个人简介及小麦苗云盘地址: http://blog.itpub.net/26736162/viewspace-1624453/

● 数据库笔试面试题库及解答: http://blog.itpub.net/26736162/viewspace-2134706/

● DBA宝典今日头条号地址: http://www.toutiao.com/c/user/6401772890/#mid=1564638659405826

........................................................................................................................

● QQ群号: 230161599 、618766405

● 微 信群:可加我微 信,我拉大家进群,非诚勿扰

● 联系我请加QQ好友 646634621 ,注明添加缘由

● 于 2019-09-01 06:00 ~ 2019-09-31 24:00 在西安完成

● 最新修改时间:2019-09-01 06:00 ~ 2019-09-31 24:00

● 文章内容来源于小麦苗的学习笔记,部分整理自网络,若有侵权或不当之处还请谅解

● 版权所有,欢迎分享本文,转载请保留出处

........................................................................................................................

小麦苗的微店https://weidian.com/s/793741433?wfr=c&ifr=shopdetail

小麦苗出版的数据库类丛书http://blog.itpub.net/26736162/viewspace-2142121/

小麦苗OCP、OCM、高可用网络班http://blog.itpub.net/26736162/viewspace-2148098/

小麦苗腾讯课堂主页https://lhr.ke.qq.com/

........................................................................................................................

使用 微 信客户端扫描下面的二维码来关注小麦苗的微 信公众号( xiaomaimiaolhr)及QQ群(DBA宝典)、添加小麦苗微 信, 学习最实用的数据库技术。

........................................................................................................................

欢迎与我联系

 

 




来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/26736162/viewspace-2655921/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论
QQ:646634621| 网名:小麦苗| 微信公众号:xiaomaimiaolhr| 11g OCM| QQ群:618766405 微信群:私聊| 《数据库笔试面试宝典》作者| OCP、OCM、高可用(RAC+DG+OGG)网络班开讲啦,有需要的小伙伴可以私聊我。

注册时间:2012-09-23

  • 博文量
    1353
  • 访问量
    8143131