ITPub博客

首页 > Linux操作系统 > Linux操作系统 > solaris 8 安装mysql3.23

solaris 8 安装mysql3.23

原创 Linux操作系统 作者:adrain_001 时间:2012-03-19 23:01:14 0 删除 编辑

我觉得装mysql几乎就是碰运气,mysql,gcc,make版本选合适了就ok,差一点都会出怪问题。主要是gcc,不知道要是用cc是不是就什么事都没有了?最后说一下我选的版本,我的系统是solaris8 sparc
mysql-3.23.55.tar.gz
gcc-3.2.2-sol8-sparc-local.gz
make-3.80-sol8-sparc-local.gz
gzip-1.3.5-sol8-sparc-local
tar-1.13.tar.gz
另外我还装了一些相关的软件
ncurses-5.3-sol8-sparc-local.gz(一定要)
autoconf-2.57-sol8-sparc-local.gz (精华贴中说要装的)
automake-1.7.2-sol8-sparc-local.gz (精华贴中说要装的)
bison-1.875-sol8-sparc-local.gz (精华贴中说要装的)
zlib-1.1.4-sol8-sparc-local.gz(这是sun网站上要求安装的)
有的时候在make的时候说缺少libstdc++,我看了它的说明文档,它已经包含在了高版本的gcc中,所以如果编译的时候出现了这样的错误估计就是mysql或是gcc的版本选的不合适了,另外我在./configure的时候参数是这么用的:
#CC=gcc CFLAGS="-O6" CXX=gcc CXXFLAGS="-O6 -felide-constructors -fno-exceptions -fno-rtti" ./configure --prefix=/usr/local/mysql --with-mysqld-user=mysql --with-charset=gbk --with-extra-charsets=all
如果只用./configure --prefix=/usr/local/mysql就会报错,错误提示就像前面说的一样。同样的方法我在装mysql的时候还用过3.23.47和3.23.53以及4.0.13都没能成功,估计是这个gcc的版本比较适合3.23.55,也可能是我的运气太差了,不过折腾了两天最后装上了还是比较高兴。
希望这些东西能给大家一点帮助。

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/26690043/viewspace-719065/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论

注册时间:2012-02-13

  • 博文量
    112
  • 访问量
    262579