ITPub博客

首页 > 数据库 > Oracle > Oracle Enterprise Linux R4U8版本下安装RAC的准备工作之oracleasmlib

Oracle Enterprise Linux R4U8版本下安装RAC的准备工作之oracleasmlib

原创 Oracle 作者:nathanzhn 时间:2014-02-18 22:38:22 0 删除 编辑
按照网络上的各类文档的介绍,需要提前安装以下rpm包:
OEL5+11g--
oracleasm-support-2.1.4-1.el5.x86_64.rpm
oracleasm-2.6.18-238.el5-2.0.5-1.el5.x86_64.rpm
oracleasmlib-2.0.4-1.el5.x86_64.rpm
而因为我的版本是OELR4U8+10g(貌似跟数据库版本没有太大关系,关键看oel的版本),我从网上找来以下几个包分别测试了一下:
-rw-r--r--  1 root root 130075 Feb 18 21:31 oracleasm-2.6.18-164.el5-2.0.5-1.el5.i686.rpm
-rw-r--r--  1 root root 124406 Nov  9  2010 oracleasm-2.6.9-89.0.0.0.1.EL-2.0.5-1.el4.src.rpm
-rw-r--r--  1 root root  13105 Nov  2  2010 oracleasmlib-2.0.4-1.el4.i386.rpm
-rw-r--r--  1 root root  13929 Feb 18 21:32 oracleasmlib-2.0.4-1.el5.i386.rpm
-rw-r--r--  1 root root  14176 Feb 18 17:32 oracleasmlib-2.0.4-1.el5.x86_64.rpm
-rw-r--r--  1 root root  82542 Nov  2  2010 oracleasm-support-2.1.3-1.el4.i386.rpm
-rw-r--r--  1 root root  85687 Feb 18 21:31 oracleasm-support-2.1.7-1.el5.i386.rpm

其中我先安装了oracleasm-support-2.1.7-1.el5.i386.rpm,并且安装成功,随后尝试安装oracleasmlib-2.0.4-1.el5.i386.rpm报错,报与linux内核版本不匹配,需要2.6.89版本的oracleasm。
但是因为在网上只找到了
oracleasm-2.6.9-89.0.0.0.1.EL-2.0.5-1.el4.src.rpm,因此需要编译一番才能安装:
rpmbuild --rebuild oracleasm-2.6.9-89.0.0.0.1.EL-2.0.5-1.el4.src.rpm
完成后cd /usr/src/redhat/RPMS/i386/进行安装:
[root@node1 i386]# ll
total 140
-rw-r--r--  1 root root 132238 Feb 18 21:46 oracleasm-2.6.9-89.0.0.0.1.EL-2.0.5-1.el4.i386.rpm
-rw-r--r--  1 root root   2409 Feb 18 21:46 oracleasm-2.6.9-89.0.0.0.1.EL-debuginfo-2.0.5-1.el4.i386.rpm
[root@node1 i386]# rpm -ivh oracleasm-2.6.9-89.0.0.0.1.EL-2.0.5-1.el4.i386.rpm
成功!
最后安装
oracleasmlib-2.0.4-1.el4.i386.rpm,也没问题,可以继续进行其他准备工作了,至于这几个rpm在后面的表现如何,现在无从判断咯!后面出现问题再进行解决和记录吧。

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/26521853/viewspace-1083461/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论

注册时间:2014-01-23

  • 博文量
    49
  • 访问量
    262702