ITPub博客

首页 > Linux操作系统 > Linux操作系统 > conditional binary operator expected

conditional binary operator expected

原创 Linux操作系统 作者:nmgzw 时间:2019-06-22 08:12:07 0 删除 编辑
执行脚本报错误如下:
install.sh: line 456: conditional binary operator expected
install.sh: line 456: syntax error near `=~'

通过查看bash版本,发现GNU bash, version 2.05b.0,对比没有问题的系统bash版本为3。
前两天曾经发现系统被入侵,因此怀疑被黑了,替换bash为3的版本,执行通过。

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/25702/viewspace-732461/,如需转载,请注明出处,否则将追究法律责任。

上一篇: gc freelist
请登录后发表评论 登录
全部评论

注册时间:2002-10-18

  • 博文量
    71
  • 访问量
    55323