ITPub博客

首页 > Linux操作系统 > Linux操作系统 > 如何处理错误消息Please install the Linux kernel header files

如何处理错误消息Please install the Linux kernel header files

原创 Linux操作系统 作者:i042416 时间:2018-10-21 14:27:09 0 删除 编辑

Please install the Linux kernel "header" files matching the current kernel

当我启动minilkube时遇到如下错误消息:

################################################################################

Minikube setup with driver virtualbox

################################################################################

Starting local Kubernetes v1.10.0 cluster...

Starting VM...

E1010 03:57:24.565157 9896 start.go:174] Error starting host: Error creating host: Error executing step: Running precreate checks.

: We support Virtualbox starting with version 5. Your VirtualBox install is "WARNING: The vboxdrv kernel module is not loaded. Either there is no module available for the current kernel (3.10.0-862.11.6.el7.x86_64) or it failed to load. Please recompile the kernel module and install it by sudo /sbin/vboxconfig You will not be able to start VMs until this problem is fixed. 5.2.18r124319". Please upgrade at  .

Retrying.

E1010 03:57:24.566250 9896 start.go:180] Error starting host: Error creating host: Error executing step: Running precreate checks.

: We support Virtualbox starting with version 5. Your VirtualBox install is "WARNING: The vboxdrv kernel module is not loaded. Either there is no module available for the current kernel (3.10.0-862.11.6.el7.x86_64) or it failed to load. Please recompile the kernel module and install it by sudo /sbin/vboxconfig You will not be able to start VMs until this problem is fixed. 5.2.18r124319". Please upgrade at 

执行命令行:

rcvboxdrv setup

vboxdrv.sh: Stopping VirtualBox services.

vboxdrv.sh: Starting VirtualBox services.

vboxdrv.sh: Building VirtualBox kernel modules.

This system is currently not set up to build kernel modules.

Please install the Linux kernel "header" files matching the current kernel

for adding new hardware support to the system.

The distribution packages containing the headers are probably:

kernel-devel kernel-devel-3.10.0-862.11.6.el7.x86_64

所以解决这个错误的关键就是:

Please install the Linux kernel "header" files matching the current kernel

执行命令行:yum install kernel-devel

Loaded plugins: product-id, search-disabled-repos, subscription-manager

This system is not registered with an entitlement server. You can use subscription-manager to register.

Resolving Dependencies

--> Running transaction check

---> Package kernel-devel.x86_64 0:3.10.0-862.14.4.el7 will be installed

--> Finished Dependency Resolution

Dependencies Resolved

========================================================================================================

Package Arch Version Repository Size

========================================================================================================

Installing:

kernel-devel x86_64 3.10.0-862.14.4.el7 rhel_7_server_rpms 16 M

Transaction Summary

========================================================================================================

Install 1 Package

Total download size: 16 M

Installed size: 37 M

Is this ok [y/d/N]:

选择Y之后,成功安装。

Install 1 Package

Total download size: 16 M

Installed size: 37 M

Is this ok [y/d/N]: y

Downloading packages:

Delta RPMs disabled because /usr/bin/applydeltarpm not installed.

kernel-devel-3.10.0-862.14.4.el7.x86_64.rpm | 16 MB 00:00:18

Running transaction check

Running transaction test

Transaction test succeeded

Running transaction

Installing : kernel-devel-3.10.0-862.14.4.el7.x86_64 1/1

Verifying : kernel-devel-3.10.0-862.14.4.el7.x86_64 1/1

Installed:

kernel-devel.x86_64 0:3.10.0-862.14.4.el7

Complete!

要获取更多Jerry的原创文章,请关注公众号"汪子熙":


来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/24475491/viewspace-2216988/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论
SAP成都研究院开发专家,SAP社区导师,SAP中国技术大使。

注册时间:2018-01-20

  • 博文量
    1874
  • 访问量
    863992