ITPub博客

首页 > 数据库 > Oracle > 在redhat as 4上安裝oracle 9204,並升級到9206

在redhat as 4上安裝oracle 9204,並升級到9206

原创 Oracle 作者:coohoo 时间:2005-11-07 17:26:42 0 删除 编辑

1。所需的Package:

rpm -q compat-db compat-gcc-32 compat-gcc-32-c++ compat-oracle-rhel4 compat-libcwait compat-libgcc-296 compat-libstdc++-296 compat-libstdc++-33 gcc gcc-c++ gnome-libs gnome-libs-devel libaio-devel libaio make openmotif21 xorg-x11-deprecated-libs-devel xorg-x11-deprecated-libs

2。KERNEL調整:

[root@hostname]#vi /etc/sysctl.conf

#添加入下文字:

kernel.shmall=2097152
kernel.shmmax=2147483648
kernel.shmmni=4096
kernel.sem=250 32000 100 128

:wq!

[root@hostname]#sysctl -p

3。升級到9206:

由於9206的patch不認redhat as4,需要修改Disk1/install/oraparam.ini欺騙oracle。

[root@hostname]#vi oraparam.ini

#注意粗體字為修改部分。

[Certified Versions]
#You can customise error message shown for failure through CERTIFIED_VERSION_FAILURE_MESSAGE
Solaris=5.6,5.7,5.8,5.9
Linux=SuSE-7,redhat-2.1AS,redhat-2.1,UnitedLinux-1.0,redhat-4,SuSE-8
HPUX=B.11.11
Decunix=V5.1A,V5.1
AIX=5.1.0.0

[Linux-redhat-2.1AS-required]
#Minimum kernel version supported on this flavour of Linux
KERNEL=2.4.21#Minimum glibc version supported on this flavour of Linux
GLIBC=glibc-2.3.4-2#PACKAGES required by JRE and Product, "rpm -qa" gets list of packages on system
PACKAGES=
#Minimum swap space required by OUI, Increase it if your product installation so requires
#SWAP_SPACE=150
SWAP_SPACE=50

[Linux-redhat-4.0-optional]TEMP_SPACE=80
SWAP_SPACE=150
MIN_DISPLAY_COLORS=256

[@more@]

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/237287/viewspace-809506/,如需转载,请注明出处,否则将追究法律责任。

上一篇: DBA学习笔记
请登录后发表评论 登录
全部评论
  • 博文量
    4
  • 访问量
    14960