ITPub博客

首页 > 应用开发 > Java > jdk版本导致tomcat,eclipse无法启动的问题

jdk版本导致tomcat,eclipse无法启动的问题

原创 Java 作者:jeanron100 时间:2014-04-07 12:16:41 0 删除 编辑
这几天从官网 下载了swingweb的demo,是一个打包好的tomcat,里面的jar包和脚本都是完整的,直接启动tomcat就可以,通过命令行java -version可以看到jdk也是安装好的。
但是启动tomcat的时候就是报错。提示jdk,jre的配置不对,我检查了几遍,环境变黄没有问题啊。
重新设置了JAVA_HOME然后再path,classpath里面重新引用也还是同样的问题。


    


然后启动eclipse,重新启动也是报错。 “Failed to load the JNI shared library"


最后的原因是Jdk有32,64位的版本,我的电脑是64位的,32位的jdk有兼容问题。
所以又安装了一个64位的jdk,问题都搞定了。

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/23718752/viewspace-1137140/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论
技术文章每天更新,阵地已转移到微信公众号端。 公众号:jianrong-notes

注册时间:2012-05-14

  • 博文量
    1498
  • 访问量
    14454785