ITPub博客

首页 > Linux操作系统 > Linux操作系统 > oracle 手动升级后组件状态为INVALID解决办法

oracle 手动升级后组件状态为INVALID解决办法

原创 Linux操作系统 作者:dzq0371 时间:2013-07-20 12:30:54 0 删除 编辑
报错信息:
oracle 10.2.0.1升级到10.2.0.5
运行catupgrd.sql后一切正常,没有出现异常。
1、在运行utlrp.sql脚本重新编译无效PL/SQL包时,出现如下错误:
ERROR at line 1:
ORA-12801: error signaled in parallel query server P064
ORA-00018: maximum number of sessions exceeded
ORA-06512: at "SYS.UTL_RECOMP", line 662
ORA-06512: at line 4

2、在运行命令检查所有组件是否成功:
SQL> select comp_name,version,status from sys.dba_registry;
出现如下错误:

COMP_NAME                                VERSION                        STATUS
---------------------------------------- ------------------------------ ----------------------
Oracle Database Catalog Views                   10.2.0.5.0                     VALID
Oracle Database Packages and Types       10.2.0.5.0                     INVALID
Oracle Workspace Manager                           10.2.0.5.0                     VALID
JServer JAVA Virtual Machine                         10.2.0.5.0                     VALID
Oracle XDK                                                         10.2.0.5.0                     VALID
Oracle Database Java Packages                   10.2.0.5.0                     INVALID
Oracle Expression Filter                                   10.2.0.5.0                     VALID
Oracle Data Mining                                            10.2.0.5.0                     INVALID
Oracle Text                                                           10.2.0.5.0                     VALID
Oracle XML Database                                        10.2.0.5.0                     VALID
Oracle Rule Manager                                         10.2.0.5.0                     INVALID
Oracle interMedia                                                10.2.0.5.0                     VALID
OLAP Analytic Workspace                                 10.2.0.5.0                     VALID
Oracle OLAP API                                                 10.2.0.5.0                     VALID
OLAP Catalog                                                     10.2.0.5.0                     VALID
Spatial                                                                  10.2.0.5.0                     INVALID
Oracle Enterprise Manager                              10.2.0.5.0                     VALID

解决办法:在网上找了很多,但试了感觉都不行。后来看到有人也是相同的问题,是由于少个包,将少我包安装后问题解决。我也只能抱着试试的态度,重新安装所有软件包,果然没有了问题。

为保险起见,在重新跑一遍升级脚本:
SQL> shutdown immediate
SQL> startup upgrade
SQL> spool upgrade.log
SQL> @?/rdbms/admin/catupgrd.sql
SQL> spool off

SQL> shutdown immediate
SQL> startup
SQL> @?/rdbms/admin/utlrp.sql
问题解决。

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/23009281/viewspace-766754/,如需转载,请注明出处,否则将追究法律责任。

上一篇: Linux下的NFS配置
请登录后发表评论 登录
全部评论

注册时间:2011-07-14

  • 博文量
    52
  • 访问量
    181695