ITPub博客

首页 > 大数据 > Hadoop > 怎样选择适合自己的php版本

怎样选择适合自己的php版本

Hadoop 作者:libing841216 时间:2012-08-11 13:40:00 0 删除 编辑

      如果自己搭配开发环境的话,往往需要自己到官方网站上下载各种组件,不过现在的官方网站几乎都是英文版的,它们认识我们,我们不认识它们,那么我们应该怎样挑选合适自己的组件呢,今天就来教教大家怎样挑选适合自己的php版本(经验之谈,并非小编英语好,本经验针对的是windows操作系统下的php挑选).

方法/步骤

  1. 1

    首先我们在百度上搜索php for windows,然后点击第一个进入官网的下载界面(避免广告嫌疑,就不打网址了),然后我们可以看到各个版本的php

  2. 2

    版本一般分为4种,VC9 x86 Non Thread Safe,VC9 x86 Thread Safe,VC6 x86 Non Thread Safe,VC6 x86 Thread Safe.首先我们来介绍VC6和VC9的区别,VC6是用legacy Visual Studio 6 compiler编译器编译的,VC9是用 Visual Studio 2008 compiler编译器编译的,如果你在windows环境下使用php+apache,应该选择VC6,如果你在windows环境下使用php+IIS,应该选择VC9

  3. 3

    VC6和VC9知道是什么意思了,那么Non Thread Safe和Thread Safe的区别呢,Non Thread Safe 就是非线程安全,在执行时不进行线程(thread)安全检查;Thread Safe就是线程安全,执行时会进行线程(thread)安全检查,以防止有新要求就启动新线程的 CGI 执行方式耗尽系统资源。

    END

注意事项

  • 相信大家对于选择VC9和VC6都有清楚的认识,至于Non Thread Safe和Thread Safe小编也不特别清楚,如果非要深入研究二者的区别的话,建议你查阅相关资料

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/22259971/viewspace-1111785/,如需转载,请注明出处,否则将追究法律责任。

上一篇: 没有了~
下一篇: 没有了~
请登录后发表评论 登录
全部评论

注册时间:2009-08-03