ITPub博客

首页 > 大数据 > Hadoop > Hadoop-2:Hadoop-Eclipse-1.1.2插件配置与安装

Hadoop-2:Hadoop-Eclipse-1.1.2插件配置与安装

Hadoop 作者:deathbody 时间:2013-05-03 11:46:50 0 删除 编辑
我们安装Hadoop-Eclipse-1.1.2插件就是为了能在Eclipse平台下进行MapReduce编程,所以此文内容实际是关于MapReduce工程创建的。

步骤一:下载Hadoop-Eclipse-Plugin-1.1.2插件。
然后确保插件里/lib目录下的各文件与/home/zhadbngiii/hadoop-1.1.2/lib目录里的版本型号一样。
若不一样,当然是要改动插件里的版本型号,使其与hadoop里的一致,不要弄反了。至于原因参考网上资料即可。
同时还要修改插件里的MANIFEST.MF文件,如图6-2所示,确保各个文件目录及版本正确,不然系统找不到。
插件配置好了,就将其放到/usr/lib/eclipse/plugin目录下,若手工移不动,用命令:
                   sudo mv 源文件 目标地址
Hadoop-2:Hadoop-Eclipse-1.1.2插件配置与安装
                                      图2-1

Hadoop-2:Hadoop-Eclipse-1.1.2插件配置与安装
                                      图2-2


步骤2:打开Eclipse软件,创建MapReduce工程。
为了确保能够连接上hadoop,我们先要将hadoop启动。若不清楚请见 Hadoop-1:Hadoop安装与配置
只要结果如下图所示,文件夹能展开,而不是Error:connection refused,那就表示hadoop配置成功,插件也配置成功。
                      Hadoop-2:Hadoop-Eclipse-1.1.2插件配置与安装
                                          图2-3

下载链接:                                  
hadoop-1.1.2下载                                 
Hadoop集群配置及MapReduce开发手册.pdf下载         
Hadoop-Eclipse-Plugin-1.1.2下载                  

网址链接:                                               
<!-- 正文结束 -->

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/21902149/viewspace-1119811/,如需转载,请注明出处,否则将追究法律责任。

上一篇: 没有了~
下一篇: 没有了~
请登录后发表评论 登录
全部评论

注册时间:2009-06-15