ITPub博客

首页 > 大数据 > Hadoop > 64位ubuntu下Android开发环境的配置

64位ubuntu下Android开发环境的配置

Hadoop 作者:leileilu 时间:2013-08-14 17:16:00 0 删除 编辑

本文介绍如何在64位ubuntu上搭建android的开发环境。

系统:ubuntu12.04LTS

使用的是ADT Bundle for Linux和jdk1.7(open jdk也可)

一共分为3步走:

1.配置JDK

  安装Open jdk

    $sudo apt-get install openjdk-7-jdk

  或

  从oracle官网下载

?  从官网下载JDK64位版

?        解压安装

     将解压出的文件用最高权限复制到/usr/lib/jvm里

    sudo cp -r ~/jdk1.7/ /usr/lib/jvm

    (中间两个“/”没有连起来,有空格)

?     修改环境变量

    sudo gedit ~/.profile

    在末尾加上

    export JAVA_HOME=/usr/lib/jvm/jdk1.7

    然后保存关闭,使用source更新一下

    $ source ~/.profile

? 配置默认的JDK版本

    $ sudo update-alternatives --install /usr/bin/java java /usr/lib/jvm/jdk1.7/bin/java 300

?    $ sudo update-alternatives --install /usr/bin/javac javac /usr/lib/jvm/jdk1.7/bin/javac 300

    $ sudo update-alternatives --config java

    $ sudo update-alternatives --config javac 

?   确认JDK是否安装成功

    $  java -version

      如果看到java version "1.7.XXXX",那么就表明安装成功了。

2.安装ADT Bundle for Linux

    从谷歌官网下载ADT Bundle for Linux,这个包包含了android sdk和eclipse,并且也已经安装好了adt。

     下载完成后直接解压到安装目录。

    也许你还要:

?   打开eclipse

?   执行Help -> Install New SoftWare...

?   单击Add...

?   在弹出的对话框中填写Name: Android Developer Tools Update Site, Location:http://dl-ssl.google.com/android/eclipse/ 

?   完成

    我做了这一步因为我在更新时发现缺少了这个站点,而不是用来安装adt。

3.安装ia32-libs

  前面的也许和32位的ubuntu安装大同小异,但是接下来这是在64位系统上必须做的,否则会出现(...adb": error=2, 没有那个文件或目录)这样的错误。原因是Android sdk只有32bit的程序,需要安装ia32-libs,才能使用。

  $ sudo apt-get install ia32-libs

  注意:ia32-libs比较大

以上只是个人的一点点见解,做任何事情都需要持之以衡的坚持。

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/21605254/viewspace-1111252/,如需转载,请注明出处,否则将追究法律责任。

上一篇: 没有了~
下一篇: 没有了~
请登录后发表评论 登录
全部评论

注册时间:2009-05-09