ITPub博客

首页 > 大数据 > Hadoop > ubuntu 12.04 LTS 安装chrome问题及解决

ubuntu 12.04 LTS 安装chrome问题及解决

Hadoop 作者:fish__ 时间:2013-10-18 20:18:00 0 删除 编辑

在ubuntu下一个必不可少的软件就是chrome浏览器,但chrome的安装却不是很顺利。以下对安装过程和期间出现的问题做个记录。

方法/步骤

  1. 1

    https://www.google.com/intl/zh-CN/chrome/browser/下载相应的版本的安装包

  2. 2

    进入下载目录:

        cd ~/Donwnloads

  3. 3

    dpkg安装chrome包:

        sudo dpkg -i google-chrome-stable_current_i386.deb

    问题1. 如无意外会出现以下错误提示,原因是依赖包的问题:

        (正在读取数据库 ... 系统当前共安装有 142688 个文件和目录。)

        正预备替换 google-chrome-stable 30.0.1599.66-1 (使用 google-chrome-stable_current_i386.deb) ...

        正在解压缩将用于更替的包文件 google-chrome-stable ...

        dpkg:依赖关系问题使得 google-chrome-stable 的配置工作不能继续:

        google-chrome-stable 依赖于 libxss1;然而:

        未安装软件包 libxss1。

        dpkg:处理 google-chrome-stable (--install)时出错:

        依赖关系问题 - 仍未被配置

        正在处理用于 desktop-file-utils 的触发器...

        正在处理用于 bamfdaemon 的触发器...

        Rebuilding /usr/share/applications/bamf.index...

        正在处理用于 gnome-menus 的触发器...

        正在处理用于 man-db 的触发器...

        在处理时有错误发生:

        google-chrome-stable

  4. 4

    根据错误提示安装libxss1依赖包:

        sudo apt-get install -f

    正在读取软件包列表... 完成

    正在分析软件包的依赖关系树       

    正在读取状态信息... 完成       

    正在更正依赖关系... 完成

    将会安装下列额外的软件包:

      libxss1

    下列【新】软件包将被安装:

      libxss1

    升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 523 个软件包未被升级。

    有 1 个软件包没有被完全安装或卸载。

    需要下载 8,604 B 的软件包。

    解压缩后会消耗掉 73.7 kB 的额外空间。

    您希望继续执行吗?[Y/n]y

  5. 5

    提示安装的时候输入y,之后chrome就安装好了

    END

注意事项

  • 如果是新安装的机子或是没有对更新源做过更新的,在第4部可能会没有反应。建议出现问题可以参考我的经验《ubuntu 12.04 LTS 如何使用更快的更新源》之后再来安装chrome。

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/21315769/viewspace-1110282/,如需转载,请注明出处,否则将追究法律责任。

上一篇: 没有了~
下一篇: 没有了~
请登录后发表评论 登录
全部评论

注册时间:2009-04-06