ITPub博客

首页 > Linux操作系统 > Linux操作系统 > python 升级

python 升级

原创 Linux操作系统 作者:zghover_cu 时间:2012-05-30 10:26:26 0 删除 编辑
在centos-5.4下升级python

在centos-5.4下自带的python是2.4的,需要升级一下:

tar jfvx Python-2.7.tar.bz2
./configure
make all
make install
make clean
make distclean
查看安装的版本信息
/usr/local/bin/python2.7 -V
Python 2.7 (r27:82500, Nov 2 2010, 19:25:22)[GCC 4.1.2 20080704 (Red Hat 4.1.2-48)] on linux2

看来新装的版本生效了,做个软连接应该就OK。

cd /usr/bin

unlink python

ln -s /usr/local/bin/python2.7  python

注意:

升级安装好以后yum会无法使用,因为yum使用的是2.4版本的,所以要修改yum的配置文件以便能够识别2.4版本下的python

vim /usr/bin/yum

将文件头部的
#!/usr/bin/python

改成

#!/usr/bin/python2.4

就可以继续使用yum了


来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/20498361/viewspace-731452/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论

注册时间:2012-03-25

  • 博文量
    12
  • 访问量
    58226