ITPub博客

首页 > Linux操作系统 > Linux操作系统 > Linux升级内核后报No volume groups found错误

Linux升级内核后报No volume groups found错误

原创 Linux操作系统 作者:sundog315 时间:2013-01-15 14:07:04 0 删除 编辑

今天尝试重新编译Linux内核,将内核版本从2.6.18-274.el5升级至2.6.39

编译过程略,新内核的make localmodconfig功能,根据内核历史使用情况,进行内核瘦身的功能很不错。

安装完毕,重启后,出现

No volume groups found
unable to find volume group "VolGroup00"

原因的老的sysfs在新版本内核中,默认不支持。

解决方法,增加如下两行:
CONFIG_SYSFS_DEPRECATED=y
CONFIG_SYSFS_DEPRECATED_V2=y

升级后一切正常。

[@more@]

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/19423/viewspace-1060106/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论

注册时间:2010-01-05

  • 博文量
    126
  • 访问量
    502722