ITPub博客

首页 > IT基础架构 > 网络安全 > ccnp学习014--路由与交换(05路由更新与控制)

ccnp学习014--路由与交换(05路由更新与控制)

原创 网络安全 作者:newdayhope 时间:2006-03-13 13:28:05 0 删除 编辑

一 管理距离控制(administrative distance)

模认的管理距离 RIP 120 IS-IS 115 OSPF 110 EIGRP 90

修改管理距离

(config-router)#distance weight [address wildcard-mask[access-list-number|name ]]

在EIGRP和BGP里修改方式.

#distance eigrp interface-distance external-distance

例子:


r1,r2,r3,r4在同一个RIPV2网络里,R1和R2是边界路由,连接的外网是172.31.3.0/24外界的网络是OSPF网络.172.31.3.0/24与172.3.1.3/24相边.分别有s0/0,s0/1,e0/0接口.

router r1

router ospf 1

redistribute rip metric 10000 metric-type 1 subnets

network 172.31.0.0 0.0.255.255 area 0

distance 125 0.0.0.0 255.255.255.255 64

!

router rip

version 2

redistribute ospf 1 metric 5

network 10.0.0.0

no auto-summary

!

access-list 64 permit 10.3.1.0

access-list 64 permit 10.3.3.0

access-list 64 permit 10.3.2.0

access-list 64 permit 10.200.200.31

access-list 64 permit 10.200.200.34

access-list 64 permit 10.200.200.32

access-list 64 permit 10.200.200.33

router r2的配置和router r1的配置差不多,二者没有太大的差别

2.PBR(policy-based routing )策略路由

用它的目的就是走一条特殊的路由,它的优点有以下几点

可以按不同的用户到达目地走不同的中径.

在Qos里设置优先级.

强制负载平衡

在端口上应用策略

(config-if)#ip policy route-map map-tag

在端口快速交换的策略

(config-if)#ip route-cache policy

验证的方法

sh ip policy

sh route-map

debug ip policy

[@more@]

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/181629/viewspace-820013/,如需转载,请注明出处,否则将追究法律责任。

下一篇: [转贴]显示问题01
请登录后发表评论 登录
全部评论
  • 博文量
    413
  • 访问量
    13191728