ITPub博客

首页 > 数据库 > Oracle > OHASD not Starting After Reboot on SLES (Doc ID 1325718.1)

OHASD not Starting After Reboot on SLES (Doc ID 1325718.1)

Oracle 作者:rongshiyuan 时间:2014-02-28 14:30:01 0 删除 编辑

OHASD not Starting After Reboot on SLES (Doc ID 1325718.1)

In this Document

  Symptoms
  Cause
  Solution
  References


Applies to:

Oracle Server - Enterprise Edition - Version: 11.2.0.2 and later   [Release: 11.2 and later ]
SUSE \ UnitedLinux x86-64
affects SuseLinux SLES 10 and SLES11

Symptoms


2 node cluster 11.2.0.2 on SLES. After reboot, clusterware does not start on either node.

There's error "Failed to install ohasd startup script, error: Inappropriate ioctl for device" from root.sh but it finished successfully.

Cause

Bug 12406573 : GRID INFRASTRUCTURE DOES NOT START AFTER REBOOT


Solution

Bug 12406573 is fixed in 11.2.0.3.

The workaround is to turn on raw service regardless whether raw device is not being used or not.

To check:

# chkconfig --list|grep raw
raw                  0:off 1:off 2:off 3:off 4:off 5:off 6:off

# chkconfig --list | grep ohasd | grep -v init
ohasd                0:off 1:off 2:off 3:off 4:off 5:off 6:off


To turn on:

as root user:
# /sbin/chkconfig raw on
# /sbin/chkconfig ohasd on

# chkconfig --list|grep raw
raw           0:off 1:off 2:off 3:on 4:off 5:on 6:off

# chkconfig --list | grep ohasd | grep -v init
ohasd         0:off 1:off 2:off 3:on 4:off 5:on 6:off

References

BUG:12406573 - GRID INFRASTRUCTURE DOES NOT START AFTER REBOOT

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/17252115/viewspace-1097087/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论

注册时间:2009-11-24

  • 博文量
    798
  • 访问量
    3268401