ITPub博客

首页 > Linux操作系统 > Linux操作系统 > libstdc++.so.6

libstdc++.so.6

原创 Linux操作系统 作者:fjmingyang 时间:2019-04-21 22:18:06 0 删除 编辑

在Redhat Linux AS 4安装apple 的darwin streaming server提示找不到libstdc++.so.6这个函数库,在网上很多说把gcc升级到3.4就可以了,可升级gcc很是麻烦,很多依赖关系。

[root@mrtg darwin]# rpm -ivh gcc4-4.0.2-14.EL4.i386.rpm
error: Failed dependencies:
        binutils >= 2.15.92.0.2-18 is needed by gcc4-4.0.2-14.EL4
        libgcc >= 3.3.2-7 is needed by gcc4-4.0.2-14.EL4

[root@mrtg darwin]# rpm -Uvh libgcc-3.4.5-2.i386.rpm
Preparing...                ########################################### [100%]
   1:libgcc                 ########################################### [100%]


[root@mrtg darwin]# rpm -Uvh binutils-2.15.92.0.2-18.i386.rpm
Preparing...                ########################################### [100%]
   1:binutils               ########################################### [100%]

[root@mrtg darwin]# rpm -Uvh gcc4-4.0.2-14.EL4.i386.rpm
Preparing...                ########################################### [100%]
        package gcc4-4.0.2-14.EL4 is already installed

[root@mrtg darwin]# gcc --version
gcc (GCC) 3.2.3 20030502 (Red Hat Linux 3.2.3-20)
Copyright (C) 2002 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

没有升级成功,不知道为什么。


其实,在redhat AS 4的disk2 上有个libstdc++-3.4.5-2.i386.rpm 安装下就可以了。

[root@mrtg darwin]# rpm -q --provides libstdc++-3.4.5-2
libstdc++ = 3.4.3-26
libstdc++.so.6 
libstdc++.so.6(CXXABI_1.3) 
libstdc++.so.6(GLIBCXX_3.4) 
libstdc++.so.6(GLIBCXX_3.4.1) 
libstdc++.so.6(GLIBCXX_3.4.2) 
libstdc++.so.6(GLIBCXX_3.4.3) 
libstdc++34 
libstdc++ = 3.4.5-2

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/1698901/viewspace-133415/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论

注册时间:2006-04-03

  • 博文量
    52
  • 访问量
    37028