ITPub博客

首页 > Linux操作系统 > Linux操作系统 > PHPMYadmin安装与配置指南

PHPMYadmin安装与配置指南

原创 Linux操作系统 作者:vcdone 时间:2008-07-08 21:51:52 0 删除 编辑

1. 获取源码包

官方网站下载地址:http://www.phpmyadmin.net/home_page/downloads.php

建议下载all-languages.tar.gz,包括所有语言,语言切换相当方便;

目前的最新版本为Version 2.11.7(2008-06-23)

2.安装到Apache服务器

假设apache服务器已配置好(apache配置在此忽略),将下载的源码包解压缩并存放在apache网页目录:

#tar zxvf phpMyAdmin-2.11.7-all-languages.tar.gz

#mv phpMyAdmin-2.11.7-all-languages /var/www/extsuite/phpmyadmin  #此为phpmyadmin网页存放路径,根据环境而定;

#cd /var/www/extsuite/phpmyadmin

#cp config.sample.inc.php config.inc.php

#nano config.inc.php

以下几项需要注意:

$cfg['blowfish_secret'] = 'COOKIE';  默认为空,需要在里面填写一些字符

启用以下两项,并填写mysql管理员的用户名和密码

$cfg['Servers'][$i]['controluser'] = 'root';
$cfg['Servers'][$i]['controlpass'] = 'yourpassword';

保存并退出;

新建目录及修改权限(但在测试时忽略此步骤亦可)

#mkdir config                        # 新建一个目录
#chmod o+rw config                   # 赋予写的权限

注意:编译或安装php环境时需启用mcrypt,否则将会出现以下错误:

无法载入 mcrypt 扩展,
请检查 PHP 配置

以上错误无法是以windows或linux为系统平台均可能会出现;

 

解决方法:安装libmcrypt:

#rpm -ivh libmcrypt-2.5.8-4.el5.centos.i386.rpm  
#rpm -ivh libmcrypt-devel-2.5.8-4.el5.centos.i386.rpm

以上两个rpm包可以去网上搜索适合自己系统平台的版本;

在编译时注意记得加上“--with-mcrypt”参数,但未安装libmcrypt前加入此参数编译将会提示出错;

在php.ini配置文件中启用extension=php_mcrypt.dll(将前面分号去掉)

 

以上配置完成后之后登陆http://yourdomainname.com/phpmyadmin如图所示:

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/15453509/viewspace-528425/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论

注册时间:2008-08-25

  • 博文量
    397
  • 访问量
    169851