ITPub博客

首页 > Linux操作系统 > Linux操作系统 > EWebEditor 支持IE7和IE8

EWebEditor 支持IE7和IE8

原创 Linux操作系统 作者:leecheery 时间:2009-05-20 09:47:54 0 删除 编辑

找到 Ewebeditor下的editor.js这个文件,可能在js下或者include文件夹下  

加入try catch 防止错误,不加应该也没问题,支持IE8,ie 7,ie6等

 

 try {
     if (navigator.appVersion.match(/8./i) == '8.' || navigator.appVersion.match(/7./i) == '7.') {
         if (element.YUSERONCLICK) eval(element.YUSERONCLICK + "onclick(event)"); //IE8 or IE7
     } else {
         if (element.YUSERONCLICK) eval(element.YUSERONCLICK + "anonymous()"); //IE6
     }
 } catch (e) {
     if (element.YUSERONCLICK) eval(element.YUSERONCLICK + "anonymous()"); //IE6
 }

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/15116811/viewspace-600524/,如需转载,请注明出处,否则将追究法律责任。

下一篇: concept
请登录后发表评论 登录
全部评论

注册时间:2008-08-22

  • 博文量
    69
  • 访问量
    100074