ITPub博客

首页 > Linux操作系统 > Linux操作系统 > Oracle 10g 导出的数据库导入9i

Oracle 10g 导出的数据库导入9i

原创 Linux操作系统 作者:zhanghuipop 时间:2009-10-15 10:59:45 0 删除 编辑

Oracle 10g 导出的数据库能导入9i 吗?

  问答:一般来说,从低版本导入到高版本问题不大,麻烦的是将高版本的数据导入到低版本中,
在Oracle9i之前,不同版本Oracle之间的EXP/IMP可以通过下面的方法来解决:

  1、在高版本数据库上运行底版本的catexp.sql;

  2、使用低版本的EXP来导出高版本的数据;

  3、使用低版本的IMP将数据库导入到底版本数据库中;

  4、在高版本数据库上重新运行高版本的catexp.sql脚本。

  但在9i中,上面的方法并不能解决问题。如果直接使用底版本EXP/IMP会出现如下错误:

  EXP-00008: ORACLE error %lu encountered

  ORA-00904: invalid column name

  这已经是一个公布的BUG,需要等到Oracle10.0才能解决,BUG号为2261722,可以到METALINK上去查看有关此BUG的详细信息。

  BUG归BUG,我们的工作还是要做,在没有Oracle的支持之前,我们就自己解决。在Oracle9i中执行下面的SQL重建exu81rls视图即可。

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/14613712/viewspace-616613/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论

注册时间:2009-10-14

  • 博文量
    21
  • 访问量
    35365