ITPub博客

首页 > Linux操作系统 > Linux操作系统 > 解决微软IE6.0的三个典型问题(转)

解决微软IE6.0的三个典型问题(转)

原创 Linux操作系统 作者:ilg 时间:2019-04-22 19:36:07 0 删除 编辑
解决微软IE6.0的三个典型问题(转)

    早在 WINDOWS XP 发布之前,IE 6.0就面世了,作为浏览器的升级版本,它既能安装在后来的 WINDOWS XP 操作系统上,也可安装于 WINDOWS 9X/ME/NT/2000 系统平台。但自从它发布以来,众多的安全问题与BUG也随之出现,"IE 6.0噩梦"之说也不径而走。下面我们就来了解一下这些问题,并提出一些相应的解决办法。我们不能保证这些办法一定能让你摆脱"IE 6.0的噩梦",但至少,它是一种新的尝试。

    一、图像自适应的问题

    A.现象:网络上,特别是一些图库网站,常常在分类页面中放置若干缩略图片,点击后可以打开一个新页面并以全屏形式对该图进行展示。如果该图的高度或宽度超出了屏幕边界,以前版本的IE就会在底边或右边出现卷栏条,让用户可以使用鼠标拖动进行查看。

    相对于以前的版本,IE 6.0多了项默认的图片自适应功能,对于超过一屏的大幅图片,它会自动以一定的比例缩小该图并始终以一屏进行显示,而不会承袭原图的尺寸。随着图像尺寸的缩小,原图在某些地方会显得比较模糊,如果你恰恰需要一幅比较清晰的原图,那该怎么办呢?

    B.解决办法:要屏蔽 IE 6.0的图片自适应问题,可以通过清除 "工具/INTERNET 选项/高级/启用自动图像大小调整"复选框来完成;要重新启用该选项,只需再勾选此复选框就行了。

    二、左右为难的JAVA

    A.现象:常有朋友来信报怨,说以前用得好好的浏览器突然登录不上JAVA网站了,或者抱怨不能玩JAVA游戏了。仔细一问,几乎都是在进行IE升级后出现类似问题的。

    B.解决办法:不能正常运行JAVA程序的原因有很多,下面我们罗列出用户平时最可能遇到的问题并提出解决方案:

    1.JAVA虚拟机(JAVA VIRTUAL MACHINE,简称JVM)缺失:对于WINDOWS XP捆绑销售整机,或是全新安装 WINDOWS XP 操作系统的电脑,JVM缺失是导致JAVA程序运行出错的最可能的原因。

    在操作系统中,JAVA程序的执行必须通过JVM来完成,但JVM并不是作为 WINDOWSXP 的默认项目进行安装的,因此,你的电脑可能没有预装JVM而导致了JAVA出错的问题。

    如果是JVM缺失,当你第一次访问有JAVA程序的网站时,会自动弹出一个对话框,叫你下载JVM.当然,这时你下载的是微软自己的JVM,而不是 SUN 公司的JAVA,因此,建议你不要进行下载,另外还是去下载 SUN 公司的JVM吧。这是因为微软自身的JVM比较"历史悠远",不能认识一些新型的JAVA程序。

    但另外一方面, SUN 公司的JVM也不尽人意,而且它还处于测试阶段,尚有不少问题。这也是我们说JAVA左右为难的原因。

    如果你确实想在 WINDOWS XP 上运行JAVA程序,我们建议你还是下载 SUN 公司的JVM.

    2.JAVA 版本号不符合:从上面我们可以看到,由于没有统一的JAVA标准,用它编写出来的程序往往会出现版本限制的问题。如果版本号不合,JAVA 程序的执行也会被中止。解决办法是:如果作者有提示,按其提示下载相关版本的JAVA.

    3.安全级别中是否已经开启JAVA功能:打开 IE ,"工具/INTERNET 选项/安全",在这里查看是否已经激活JAVA.高级别的安全方案会自动屏蔽JAVA功能,这时你就需要降低安全级别并启用JAVA功能。

    4.显卡的设置:不是最优配置的显卡驱动,在 WINDOWS XP 环境下也常常是导致JAVA出错的原因。如果前面几种方法都不能解决JAVA运行的问题,可以试试显卡设置的方法。

    在桌面上任意空白处点击鼠标右键,"属性/设置",弹出如图三的面板:

    试着将颜色模式调低,如256色;分辩率也调低点,如800X600的解析度就行了,然后系统重启,再运行该JAVA程序。

    如果此时能运行JAVA了,那么说明你的显卡驱动有问题,去升级吧。

    5.重装JVM:如果以上的办法都不管用,那么就只能重装JVM了。但请注意,重装JVM跟装其他软件不一样,如果你的电脑曾装有某个版本的JVM,那么首先你得将其完全卸载(包括相关的注册表信息),然后再安装新的JVM,否则会报错甚至让整个操作系统瘫痪!

    另外,在彻底删除JAVA前,最好将 C:WINDOWSJAVA目录中的文件做个备份。

    三、无法浏览采用安全机制的网站

    A.现象:安装IE 6.0之前,浏览器可以正常浏览采用安全机制的网站,如在线购物网站;浏览器升级后无法浏览,浏览器或者返回无法打开的网页文件,或者报告加密机制出错。

    B.解决办法:安装IE 6.0时,常常会破坏原有的动态链接库(DYNAMIC LINK LIBRARIES),浏览器不能浏览加密网站,极有可能是因为支持 128 位加密功能的动态链接文件受损,这时就必须对相关的动态链接加以修复。

    首先下载加密数据包(下载地址),然后运行。由于已经安装了IE 6.0,数据包运行时会报告已经安装了128位加密协议,不需要再下载了。不管它,继续运行,完成后就修复了。

    当然,还有另外一种可能,就是不小心屏蔽了IE的SSL加密协议。打开IE 6.0,"工具/INTERNET 选项/高级/安全",然后找到"使用SSL 2.0"、"使用SSL 3.0"选项,看前面的复选框是否勾选。

    SSL是网络数据加密协议,必须在启用它后才能浏览具有安全机制的网站。

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/14102/viewspace-115282/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论

注册时间:2002-06-18

  • 博文量
    1715
  • 访问量
    1291828