ITPub博客

首页 > Linux操作系统 > Linux操作系统 > 安装NetWeaver 搜集 资料中

安装NetWeaver 搜集 资料中

原创 Linux操作系统 作者:fengleihen 时间:2009-04-10 14:44:43 0 删除 编辑
http://blog.sina.com.cn/s/blog_5f1f36ed0100cf70.html
http://abaper.blogbus.com/logs/37232279.html
https://www.sdn.sap.com/irj/scn/thread?messageID=6322939

安装环境:sap版本:SAP NetWeaver Composition environment 7[1].1 ehp1 (Preview Version)

操作系统:Windows XP SP2 中文版

内存:1G

真正的麻烦在step 18,日志窗口提示根本就不对,主要看sapinst.log这个文件,关于错误的几个关键字是:

FATAL: Main class "com.sap.security.core.server.secstorefs.SecStoreFS" cannot be started:

Caused by: java.lang.SecurityException: Cannot set up certs for trusted CAs

Caused by: java.lang.SecurityException: Cannot locate policy or framework files!

google了半天,在sdn上面找到一个类似的帖子:about install of SAP NetWeaver Composition Environment 7.1 SR5 - Trial

在第18步出错的时候,把安装步骤中在sun下载的jce_policy-1_5_0.zip文件进行解压缩,将其中的local_policy.jar和US_export_policy.jar两个文件,复制到安装ce的临时路径中。我选择的是typical按照模式,这个路径是C:\Program Files\sapinst_instdir\CE71_DEV_ADA\INSTALL\sapjvm\sapjvm_5\jre\lib\security。然后点击Retry按钮继续安装。(我是直接cancel掉,重新继续安装,Retry等了一个小时没反应的)

在第27步出现类似的错误,把上面步骤的两个文件复制到ce的安装后的路径,在typical安装模式这个路径是d:\usr\sap\CE1\SYS\exe\jvm\NTI386\sapjvm_5.1.017\sapjvm_5\jre\lib\security。然后点击Retry按钮继续安装。(我是直接cancel掉,重新继续安装,点Retry等了一个小时没反应的)

装好了,也没有费多大的劲,不过服务启动不起来,老是黄色的,报以下错误:

Error: -6 Version: 7011 Component: ICM Java Date/Time: Sun Apr 12 22:19:06 2009 Module: http_j2ee2.c Line: 769 Server: nwce711ehp1_CE1_00 Error Tag: {-} Detail: ICM running but no server with HTTP connected

还以为内存不够,所以就去买了跟2g的,问题依旧,然后发现了我禁用了好多服务启动下就好了,具体那些没有研究。然后每次启动最少要等10分钟-20分钟左右!

* 转载自 日积月累 博客

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/139677/viewspace-587001/,如需转载,请注明出处,否则将追究法律责任。

下一篇: begin study
请登录后发表评论 登录
全部评论

注册时间:2009-03-31

  • 博文量
    24
  • 访问量
    26533