ITPub博客

首页 > 数据库 > MySQL > mysql 5.5.9 导出导入到5.1.41 的问题

mysql 5.5.9 导出导入到5.1.41 的问题

原创 MySQL 作者:babyyellow 时间:2014-03-24 15:01:36 0 删除 编辑
今天更新测试库,
从线上数据库 更新几个表到测试库

在5.5 的线上数据库导出单个表后,导入到测试库,测试库是5.1.41 

导出3个表,只有一个表可以顺利导入另外两个表报错

并且是同样的错误

[root@test740-10 ~]# mysql  test < /usr/local/mysql/cs_acc1.sql 
ERROR at line 79: Unknown command '\''.



大体的错误形式就是这个样子的,起初有点郁闷,以为是字符集的问题,改了字符集导出导入,同样的错误


难道是某些字符型的内容异常, 单引号的闭合有问题? 

看了下版本,测试库是5.1 线上是5.5 难道是版本的问题引起的? 

于是测试了下,同样的导出文件,导入到5.5 版本的数据库是没有问题的

看来是数据库版本问题了。 于是就远程用5.1.41 版本的mysqldump 导出然后导入,一切kok 


看来 从高版本导入到低版本还是有一定风险的。


这里似乎应该是跟某些值相关的,导出的3个表中,一个是可以直接导入的,另外的两个则报了同样的错误。


具体的问题需要再继续深入的分析。 

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/133735/viewspace-1128324/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论
oracle MySQL Postgresql 专职数据库dba。 系统架构师。 mysql 官方认知dba 。 15年专职dba 经验。

注册时间:2010-12-02

  • 博文量
    252
  • 访问量
    1490873