ITPub博客

首页 > Linux操作系统 > Linux操作系统 > RMAN-06429: TARGET database is not compatible with this versi on o f RMAN

RMAN-06429: TARGET database is not compatible with this versi on o f RMAN

原创 Linux操作系统 作者:dla001 时间:2011-05-11 13:52:17 0 删除 编辑

环境:

M1: redhat5     DB_VERSION: 10GR2  32bit  (target)

M2: redhat5 X64   DB_VERSION:11GR2  64bit  (catalog)

在M2上执行命令:

rman target sys/password@tns_target   catalog rman/rman@tns_catalog

报错如标题:

查找资料结果如下:

资料内容来自:OCP认证考试指南 11G(051,052,053)   -> 高级RMAN功能 ->532页

常用方法(错误解决方法):做为SYS用户采用操作系统身份认证连接到一个本地数据库,然后作为RMAN用户使用Oracle Net连接到一个远程目录数据库。

RMAN可执行文件的版本必须与目标数据库的版本相同,如果使用相同的Oracle Home从目标数据库中本地运行它,那么总能符合要求。RMAN可执行文件不必与RMAN目录的版本相同,因此跨网络连接它时不会有问题。

创建目录的RMAN版本要等于或高于目标数据库。

RMAN可执行文件的版本必须与目标数据库相同,并且低于或等于用来创建目录的RMAN版本。

CATALOG的RMAN版本低的话,请UPDATE.

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/12807983/viewspace-694995/,如需转载,请注明出处,否则将追究法律责任。

上一篇: 没有了~
请登录后发表评论 登录
全部评论

注册时间:2011-04-28

  • 博文量
    40
  • 访问量
    48943