ITPub博客

首页 > 数据库 > MySQL > 安装MySQL 5.6.10包冲突问题

安装MySQL 5.6.10包冲突问题

原创 MySQL 作者:pxbibm 时间:2016-05-09 09:09:51 0 删除 编辑

Liunx操作系统默认会安装 mysql-libs-5.1.73-5.el6_6.x86_64等lib文件,这样就会与MySQL5.6.10的安装文件冲突,第一次安装情况如下(conflicts with是冲突的意思):

[root@master ~]# rpm -ivh MySQL-server-advanced-5.6.25-1.rhel5.x86_64.rpm
Preparing...                ########################################### [100%]
  file /usr/share/mysql/czech/errmsg.sys from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/danish/errmsg.sys from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/dutch/errmsg.sys from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/english/errmsg.sys from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/estonian/errmsg.sys from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/french/errmsg.sys from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/german/errmsg.sys from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/greek/errmsg.sys from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/hungarian/errmsg.sys from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/italian/errmsg.sys from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/japanese/errmsg.sys from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/korean/errmsg.sys from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/norwegian-ny/errmsg.sys from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/norwegian/errmsg.sys from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/polish/errmsg.sys from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/portuguese/errmsg.sys from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/romanian/errmsg.sys from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/russian/errmsg.sys from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/serbian/errmsg.sys from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/slovak/errmsg.sys from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/spanish/errmsg.sys from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/swedish/errmsg.sys from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/ukrainian/errmsg.sys from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/Index.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/README from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/armscii8.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/ascii.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/cp1250.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/cp1251.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/cp1256.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/cp1257.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/cp850.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/cp852.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/cp866.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/dec8.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/geostd8.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/greek.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/hebrew.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/hp8.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/keybcs2.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/koi8r.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/koi8u.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/latin1.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/latin2.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/latin5.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/latin7.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/macce.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/macroman.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64
  file /usr/share/mysql/charsets/swe7.xml from install of MySQL-server-advanced-5.6.25-1.rhel5.x86_64 conflicts with file from package mysql-libs-5.1.73-5.el6_6.x86_64

解决办法如下:

先查看系统下有哪些包含MySQL字符串的包,再把查到的mysql-libs-5.1.73-5.el6_6.x86_64这个包卸载掉。

[root@master ~]#  rpm -qa |grep -i mysql
mysql-devel-5.1.73-5.el6_6.x86_64
mysql-libs-5.1.73-5.el6_6.x86_64

[root@master ~]# rpm -ev --nodeps mysql-libs-5.1.73-5.el6_6.x86_64
[root@master ~]#  rpm -qa |grep -i mysql
mysql-devel-5.1.73-5.el6_6.x86_64
[root@master ~]#
[root@master ~]#
[root@master ~]#

最后再重新执行安装命令即可:
[root@master ~]# rpm -ivh MySQL-server-advanced-5.6.25-1.rhel5.x86_64.rpm
Preparing...                ########################################### [100%]
   1:MySQL-server-advanced  ########################################### [100%]
warning: user mysql does not exist - using root
warning: group mysql does not exist - using root

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/12798004/viewspace-2096151/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论
  • 博文量
    240
  • 访问量
    2160665