ITPub博客

首页 > 数据库 > Oracle > java 编译问题:Bad version number

java 编译问题:Bad version number

Oracle 作者:myfriend20 时间:2013-07-31 13:45:00 0 删除 编辑

java.lang.UnsupportedClassVersionError: Bad version number in .class file
造成这种过错是ni的支撑Tomcat运行的JDK版本与支撑application运行的JDK版本不一致导致的

方法/步骤

  1. 1

    Window --> Preferences -->Java --> compiler中的compiler compliance level对应的下拉菜单中选择JDK版本.

  2. 2

    Window --> Preferences -->MyEclipse --> Servers -->Tomcat --> Tomcat n.x -->JDK中的Tomcat JDK name下的下拉菜单中选择自身电脑上安装的JDK版本(必需与步骤1中的JDK版本一致).

    END

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/11677914/viewspace-1109350/,如需转载,请注明出处,否则将追究法律责任。

上一篇: 没有了~
下一篇: 没有了~
请登录后发表评论 登录
全部评论