ITPub博客

首页 > IT基础架构 > 网络安全 > tomcat中,目标版本 1.3 与默认的源版本 1.5 冲突错误的解决

tomcat中,目标版本 1.3 与默认的源版本 1.5 冲突错误的解决

原创 网络安全 作者:figo886 时间:2007-10-19 20:59:01 0 删除 编辑
开发JSP,使用Eclipse(JDK1.5),部署WEB应用Tomcat5.0.29
请求JSP时,Tomcat日志显示“javac: 目标版本 1.3 与默认的源版本 1.5 冲突”
查看上面的错误日志,发现"compilerTargetVM=1.3",应该时Tomcat的JSP编译时使用的JDK1.3的版本。
进行如下修改:

找到tomcat conf目录下的web.xml,将这段内容:


jsp
org.apache.jasper.servlet.JspServlet

fork
false


xpoweredBy
false

3


改为如下


jsp
org.apache.jasper.servlet.JspServlet

compilerSourceVM
1.5


compilerTargetVM
1.5


fork
false


compiler
modern


xpoweredBy
false

3


重新启动Tomcat,问题解决。

http://blog.chinaitlab.com/user1/1487539/index.html

[@more@]开发JSP,使用Eclipse(JDK1.5

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/11677396/viewspace-977635/,如需转载,请注明出处,否则将追究法律责任。

下一篇: 没有了~
请登录后发表评论 登录
全部评论
  • 博文量
    4
  • 访问量
    101044