ITPub博客

首页 > Linux操作系统 > Linux操作系统 > 公司环境redhat as5 安装Oracle 10g的文档

公司环境redhat as5 安装Oracle 10g的文档

原创 Linux操作系统 作者:ljm0211 时间:2012-06-20 16:02:37 0 删除 编辑
patch for oracle10gR2

先执行patch1,再执行patch2
           
rpm -Uvh compat-libstdc++-3.2-1.i386.rpm
           

-rw-r--r-- 1 root root 3016394 Aug 20 14:03 binutils-2.17.50.0.6-6.0.1.el5.i386.rpm
-rw-r--r-- 1 root root   410476 Aug 20 13:52 compat-binutils215-2.15.92.0.2-24.i386.rpm
-rw-r--r-- 1 root root     4256 Aug 20 13:55 compat-libcwait-2.1-1.i386.rpm
-rw-r--r-- 1 root root 3552095 Aug 20 14:08 compat-libstdc++-3.2-1.i386.rpm
-rw-r--r-- 1 root root    88787 Aug 20 14:03 compat-libstdc++-egcs-1.1.2-1.i386.rpm
-rw-r--r-- 1 root root     3840 Aug 20 14:04 compat-oracle-el5-1.0-5.i386.rpm
-rw-r--r-- 1 root root 15427327 Aug 20 16:15 fonts-chinese-3.02-12.el5.noarch.rpm
-rw-r--r-- 1 root root 1079629 Aug 20 14:08 openmotif21-2.1.30-11.EL5.i386.rpm
-rw-r--r-- 1 root root   122314 Aug 20 14:09 openmotif21-debuginfo-2.1.30-11.EL5.i386.rpm
-rw-r--r-- 1 root root    10662 Aug 20 14:06 xorg-x11-libs-compat-6.8.2-1.EL.33.0.1.i386.rpm


[root@zj-zkrapp01 patches]# rpm -Uvh compat-libstdc++-3.2-1.i386.rpm
error: Failed dependencies:
        libstdc++ = 4.1.2-42.el5 is needed by (installed) libstdc++-devel-4.1.2-42.el5.i386
        libstdc++ = 4.1.2-42.el5 is needed by (installed) gcc-c++-4.1.2-42.el5.i386
        libstdc++.so.6 is needed by (installed) libusb-0.1.12-5.1.i386
        libstdc++.so.6 is needed by (installed) db4-4.3.29-9.fc6.i386
        libstdc++.so.6 is needed by (installed) libtiff-3.8.2-7.el5.i386
        libstdc++.so.6 is needed by (installed) beecrypt-4.1.2-10.1.1.i386
        libstdc++.so.6 is needed by (installed) flac-1.1.2-28.el5_0.1.i386
        libstdc++.so.6 is needed by (installed) pcre-6.6-2.el5_1.7.i386
        libstdc++.so.6 is needed by (installed) aspell-0.60.3-7.1.i386
        libstdc++.so.6 is needed by (installed) groff-1.18.1.1-11.1.i386
        libstdc++.so.6 is needed by (installed) festival-1.95-5.2.1.i386
        libstdc++.so.6 is needed by (installed) iptstate-1.4-1.1.2.2.i386
        libstdc++.so.6 is needed by (installed) ttmkfdir-3.0.9-23.el5.i386
        libstdc++.so.6 is needed by (installed) dvd+rw-tools-7.0-0.el5.3.i386
        libstdc++.so.6 is needed by (installed) libmusicbrainz-2.1.1-4.1.i386
        libstdc++.so.6 is needed by (installed) cdrdao-1.2.1-2.i386
        libstdc++.so.6 is needed by (installed) mesa-libGLU-6.5.1-7.5.el5.i386
        libstdc++.so.6 is needed by (installed) opensp-1.5.2-4.i386
        libstdc++.so.6 is needed by (installed) openjade-1.3.2-27.i386
        libstdc++.so.6 is needed by (installed) cups-1.2.4-11.18.el5.i386
        libstdc++.so.6 is needed by (installed) redhat-lsb-3.1-12.3.EL.i386
        libstdc++.so.6 is needed by (installed) hpijs-1.6.7-4.1.el5_0.3.i386
        libstdc++.so.6 is needed by (installed) poppler-0.5.4-4.4.el5_1.i386
        libstdc++.so.6 is needed by (installed) lftp-3.5.1-2.fc6.i386
        libstdc++.so.6 is needed by (installed) coolkey-1.1.0-6.el5.i386
        libstdc++.so.6 is needed by (installed) gmp-4.1.4-10.el5.i386
        libstdc++.so.6 is needed by (installed) libstdc++-devel-4.1.2-42.el5.i386
        libstdc++.so.6 is needed by (installed) libicu-3.6-5.11.1.i386
        libstdc++.so.6 is needed by (installed) boost-1.33.1-10.el5.i386
        libstdc++.so.6 is needed by (installed) swig-1.3.29-2.el5.i386
        libstdc++.so.6 is needed by (installed) doxygen-1.4.7-1.1.i386
        libstdc++.so.6 is needed by (installed) systemtap-0.6.2-1.el5.i386
        libstdc++.so.6 is needed by (installed) oprofile-0.9.3-16.el5.i386
        libstdc++.so.6 is needed by (installed) frysk-0.0.1.2008.03.19.rh1-1.el5.i686
        libstdc++.so.6 is needed by (installed) xulrunner-1.9-0.beta5.6.el5.i386
        libstdc++.so.6 is needed by (installed) ghostscript-8.15.2-9.1.el5_1.1.i386
        libstdc++.so.6 is needed by (installed) yelp-2.16.0-18.el5.i386
        libstdc++.so.6 is needed by (installed) firefox-3.0-0.beta5.6.el5.i386
        libstdc++.so.6 is needed by (installed) evince-0.6.0-8.el5.i386
        libstdc++.so.6 is needed by (installed) vnc-server-4.1.2-9.el5.i386
        libstdc++.so.6 is needed by (installed) xulrunner-devel-1.9-0.beta5.6.el5.i386
        libstdc++.so.6 is needed by (installed) sound-juicer-2.16.0-3.el5.i386
        libstdc++.so.6 is needed by (installed) scim-libs-1.4.4-39.el5.i386
        libstdc++.so.6 is needed by (installed) scim-1.4.4-39.el5.i386
        libstdc++.so.6 is needed by (installed) scim-tables-0.5.6-7.i386
        libstdc++.so.6 is needed by (installed) scim-bridge-0.4.5-7.el5.i386
        libstdc++.so.6 is needed by (installed) wvdial-1.54.0-5.2.2.1.i386
        libstdc++.so.6 is needed by (installed) scim-pinyin-0.5.91-16.el5.i386
        libstdc++.so.6 is needed by (installed) scim-chewing-0.3.1-11.el5.i386
        libstdc++.so.6 is needed by (installed) scim-chinese-standard-0.0.2-1.el5.i386
        libstdc++.so.6 is needed by (installed) stardict-2.4.5-5.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) libusb-0.1.12-5.1.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) db4-4.3.29-9.fc6.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) libtiff-3.8.2-7.el5.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) beecrypt-4.1.2-10.1.1.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) flac-1.1.2-28.el5_0.1.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) pcre-6.6-2.el5_1.7.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) aspell-0.60.3-7.1.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) groff-1.18.1.1-11.1.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) festival-1.95-5.2.1.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) iptstate-1.4-1.1.2.2.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) ttmkfdir-3.0.9-23.el5.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) dvd+rw-tools-7.0-0.el5.3.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) libmusicbrainz-2.1.1-4.1.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) cdrdao-1.2.1-2.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) mesa-libGLU-6.5.1-7.5.el5.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) opensp-1.5.2-4.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) openjade-1.3.2-27.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) cups-1.2.4-11.18.el5.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) hpijs-1.6.7-4.1.el5_0.3.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) poppler-0.5.4-4.4.el5_1.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) coolkey-1.1.0-6.el5.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) gmp-4.1.4-10.el5.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) libicu-3.6-5.11.1.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) boost-1.33.1-10.el5.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) swig-1.3.29-2.el5.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) doxygen-1.4.7-1.1.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) oprofile-0.9.3-16.el5.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) frysk-0.0.1.2008.03.19.rh1-1.el5.i686
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) xulrunner-1.9-0.beta5.6.el5.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) yelp-2.16.0-18.el5.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) evince-0.6.0-8.el5.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) vnc-server-4.1.2-9.el5.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) xulrunner-devel-1.9-0.beta5.6.el5.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) scim-libs-1.4.4-39.el5.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) scim-1.4.4-39.el5.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) scim-tables-0.5.6-7.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) scim-bridge-0.4.5-7.el5.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) scim-pinyin-0.5.91-16.el5.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) scim-chewing-0.3.1-11.el5.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) scim-chinese-standard-0.0.2-1.el5.i386
        libstdc++.so.6(CXXABI_1.3) is needed by (installed) stardict-2.4.5-5.i386
        libstdc++.so.6(CXXABI_1.3.1) is needed by (installed) opensp-1.5.2-4.i386
        libstdc++.so.6(CXXABI_1.3.1) is needed by (installed) vnc-server-4.1.2-9.el5.i386
        libstdc++.so.6(CXXABI_1.3.1) is needed by (installed) scim-pinyin-0.5.91-16.el5.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) libusb-0.1.12-5.1.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) db4-4.3.29-9.fc6.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) libtiff-3.8.2-7.el5.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) beecrypt-4.1.2-10.1.1.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) flac-1.1.2-28.el5_0.1.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) pcre-6.6-2.el5_1.7.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) aspell-0.60.3-7.1.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) groff-1.18.1.1-11.1.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) festival-1.95-5.2.1.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) iptstate-1.4-1.1.2.2.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) ttmkfdir-3.0.9-23.el5.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) dvd+rw-tools-7.0-0.el5.3.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) libmusicbrainz-2.1.1-4.1.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) cdrdao-1.2.1-2.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) mesa-libGLU-6.5.1-7.5.el5.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) opensp-1.5.2-4.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) openjade-1.3.2-27.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) cups-1.2.4-11.18.el5.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) hpijs-1.6.7-4.1.el5_0.3.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) poppler-0.5.4-4.4.el5_1.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) coolkey-1.1.0-6.el5.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) gmp-4.1.4-10.el5.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) libicu-3.6-5.11.1.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) boost-1.33.1-10.el5.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) swig-1.3.29-2.el5.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) doxygen-1.4.7-1.1.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) systemtap-0.6.2-1.el5.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) oprofile-0.9.3-16.el5.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) xulrunner-1.9-0.beta5.6.el5.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) yelp-2.16.0-18.el5.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) firefox-3.0-0.beta5.6.el5.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) vnc-server-4.1.2-9.el5.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) xulrunner-devel-1.9-0.beta5.6.el5.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) scim-libs-1.4.4-39.el5.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) scim-1.4.4-39.el5.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) scim-tables-0.5.6-7.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) scim-bridge-0.4.5-7.el5.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) scim-pinyin-0.5.91-16.el5.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) scim-chewing-0.3.1-11.el5.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) scim-chinese-standard-0.0.2-1.el5.i386
        libstdc++.so.6(GLIBCXX_3.4) is needed by (installed) stardict-2.4.5-5.i386
        libstdc++.so.6(GLIBCXX_3.4.5) is needed by (installed) boost-1.33.1-10.el5.i386
        /usr/lib/libstdc++.so.6 is needed by (installed) libstdc++-devel-4.1.2-42.el5.i386
[root@zj-zkrapp01 patches]#

[root@zj-zkrapp01 patches]# rpm -Uvh compat-oracle-el5-1.0-5.i386.rpm
error: Failed dependencies:
        compat-gcc-34 is needed by compat-oracle-el5-1.0-5.i386
        compat-gcc-34-c++ is needed by compat-oracle-el5-1.0-5.i386
        openmotif21 is needed by compat-oracle-el5-1.0-5.i386
[root@zj-zkrapp01 patches]#

[root@zj-zkrapp01 patches]# rpm -Uvh fonts-chinese-3.02-12.el5.noarch.rpm
warning: fonts-chinese-3.02-12.el5.noarch.rpm: Header V3 DSA signature: NOKEY, key ID 1e5e0159
Preparing...                ########################################### [100%]
        package fonts-chinese-3.02-12.el5 is already installed
        file /usr/share/fonts/chinese/misc/taipei16.pcf.gz from install of fonts-chinese-3.02-12.el5 conflicts with file from package fonts-chinese-3.02-12.el5
        file /usr/share/fonts/chinese/misc/taipei20.pcf.gz from install of fonts-chinese-3.02-12.el5 conflicts with file from package fonts-chinese-3.02-12.el5
        file /usr/share/fonts/chinese/misc/taipei24.pcf.gz from install of fonts-chinese-3.02-12.el5 conflicts with file from package fonts-chinese-3.02-12.el5
[root@zj-zkrapp01 patches]#

[root@zj-zkrapp01 patches]# rpm -Uvh openmotif21-2.1.30-11.EL5.i386.rpm
error: Failed dependencies:
        libXp.so.6 is needed by openmotif21-2.1.30-11.EL5.i386


create unix account
       
password1
oratest1 / oraapp01

groupadd -g 401 dba
useradd -u 501 -d /home/oratest1 -g dba oratest1
passwd oratest1

configure kernel parameters for oracle10g

vi /etc/sysctl.conf
# Controls the maximum shared segment size, in bytes
kernel.shmmax = 4294967295

# Controls the maximum number of shared memory segments, in pages
kernel.shmall = 268435456

# added in 2009/08/21
kernel.shmmni = 4096
# semaphores: semmsl, semmns, semopm, semmni
kernel.sem = 250 32000 100 128
net.ipv4.ip_local_port_range = 1024 65000
net.core.rmem_default=262144
net.core.rmem_max=262144
net.core.wmem_default=262144
net.core.wmem_max=262144

refreshing...
[root@zj-zkrapp01 ~]# /sbin/sysctl -p

vi /etc/security/limits.conf
# use for oracle
*       soft    nproc   2047
*       hard    nproc   16384
*       soft    nofile 1024
*       hard    nofile 65536

vi /etc/pam.d/login 行末添加以下内容
session required pam_limits.so

安装的时候加忽略操作系统判断的参数 ./runInstaller -ignoresysprereqs

伪造为版本4,否则不能安装!安装完成后再更改回来。
vi /etc/redhat-release
Red Hat Enterprise Linux Server release 5.2 (Tikanga)

更改为:
redhat-4


hosts和DNS的设置导致安装出错:
An unexpected exception has been detected in native code outside the VM.
Unexpected Signal : 11 occurred at PC=0x312613  
Function=index+0x63
Library=/lib/i686/nosegneg/libc.so.6

Current Java thread:
        at oracle.net.common.NetGetEnv.getDNSDomain(Native Method)
        at oracle.net.ca.ConfigureProfile.setDefaultProfileParams(Unknown Source)
        at oracle.net.ca.InitialSetup.setupConfigObjects(Unknown Source)
        at oracle.net.ca.InitialSetup.(Unknown Source)
        at oracle.net.ca.NetCA.main(Unknown Source)

更改hosts及resolv.conf为:       
[root@zj-zkrapp01 etc]# cat /etc/hosts
# Do not remove the following line, or various programs
# that require network functionality will fail.
# 127.0.0.1     zkrapp01        localhost.localdomain   localhost
::1     localhost6.localdomain6 localhost6
88.0.33.17      zj-zkrapp01     localhost.localdomain   localhost
[root@zj-zkrapp01 etc]# cat resolv.conf
# domainname     zking.com
# nameserver 66.0.32.5
# nameserver 66.0.32.6
[root@zj-zkrapp01 etc]#

选择数据库字符集:ZHS16GBK
1* select * from V$NLS_PARAMETERS
SQL> /

PARAMETER                      VALUE
------------------------------ ------------------------------
NLS_LANGUAGE                   SIMPLIFIED CHINESE
NLS_TERRITORY                  CHINA
NLS_CURRENCY                   ¥
NLS_ISO_CURRENCY               CHINA
NLS_NUMERIC_CHARACTERS         .,
NLS_CALENDAR                   GREGORIAN
NLS_DATE_FORMAT                YYYY-MM-DD HH24:MI:SS
NLS_DATE_LANGUAGE              SIMPLIFIED CHINESE
NLS_CHARACTERSET               ZHS16GBK
NLS_SORT                       BINARY
NLS_TIME_FORMAT                HH.MI.SSXFF AM
NLS_TIMESTAMP_FORMAT           DD-MON-RR HH.MI.SSXFF AM
NLS_TIME_TZ_FORMAT             HH.MI.SSXFF AM TZR
NLS_TIMESTAMP_TZ_FORMAT        DD-MON-RR HH.MI.SSXFF AM TZR
NLS_DUAL_CURRENCY              ¥
NLS_NCHAR_CHARACTERSET         AL16UTF16
NLS_COMP                       BINARY
NLS_LENGTH_SEMANTICS           BYTE
NLS_NCHAR_CONV_EXCP            FALSE

已选择19行。

generate database creation scripts: /home/oratest1/admin/test1/scripts

OEM:
the database control URL is http://zj-zkrapp01:1158/em

[root@zj-zkrapp01 etc]# cd /home/oratest1
[root@zj-zkrapp01 oratest1]# cd oraInventory
[root@zj-zkrapp01 oraInventory]# ls *.sh
orainstRoot.sh
[root@zj-zkrapp01 oraInventory]# ./orainstRoot.sh
Changing permissions of /home/oratest1/oraInventory to 770.
Changing groupname of /home/oratest1/oraInventory to dba.
The execution of the script. is complete
[root@zj-zkrapp01 oraInventory]# cd ..
[root@zj-zkrapp01 oratest1]# pwd
/home/oratest1
[root@zj-zkrapp01 oratest1]# cd ora10g
[root@zj-zkrapp01 ora10g]# ls *.sh
root.sh
[root@zj-zkrapp01 ora10g]# ./root.sh
Running Oracle10 root.sh script...

The following environment variables are set as:
    ORACLE_OWNER= oratest1
    ORACLE_HOME= /home/oratest1/ora10g

Enter the full pathname of the local bin directory: [/usr/local/bin]:
   Copying dbhome to /usr/local/bin ...
   Copying oraenv to /usr/local/bin ...
   Copying coraenv to /usr/local/bin ...


Creating /etc/oratab file...
Entries will be added to the /etc/oratab file as needed by
Database Configuration Assistant when a database is created
Finished running generic part of root.sh script.
Now product-specific root actions will be performed.
[root@zj-zkrapp01 ora10g]#

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/11411056/viewspace-733422/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论

注册时间:2009-05-14

  • 博文量
    272
  • 访问量
    436831