ITPub博客

首页 > Linux操作系统 > Linux操作系统 > LOG_ARCHIVE_DEST_2 Fails With ORA-1031 [ID 259142.1]

LOG_ARCHIVE_DEST_2 Fails With ORA-1031 [ID 259142.1]

原创 Linux操作系统 作者:thompsun 时间:2011-01-20 23:48:38 0 删除 编辑

In this Document
  Symptoms
  Cause
  Solution
  References


Applies to:

Oracle Server - Enterprise Edition - Version: 10.1.0.2 to 10.1.0.2 - Release: 10.1 to 10.1
Information in this document applies to any platform.

Symptoms

When configuring log transport services for Streams Downstream capture, you may encounter this situation.
On the source database, the remote archive destination might to be specified as follows :
log_archive_dest_2 = 'SERVICE=TEST10.IDC.ORACLE.COM LGWR MANDATORY NOREGISTER
REOPEN=120'
However, an attempt to ship the log to the remote destination will fail with errors like :

ORA-16014: log 3 sequence# 10 not archived, no available destinations
ORA-00312: online log 3 thread 1: 'F:\V10\ORADATA\V10\REDO03.LOG'


The generated trace file contains :

Redo shipping client performing standby login
OCISessionBegin failed -1
Detailed OCI error val is 1031 and errmsg is 'ORA-01031: insufficient privileges


*** 2003-11-30 18:55:30.937 49871 kcrr.c
Error 1031 received logging on to the standby
Error 1031 connecting to destination LOG_ARCHIVE_DEST_2 standby host 'TEST10'
Error 1031 attaching to destination LOG_ARCHIVE_DEST_2 standby host 'TEST10'
ORA-01031: insufficient privileges
*** 2003-11-30 18:55:30.984 49871 kcrr.c
ARC1: Heartbeat failed to connect to standby 'TEST10'. Error is 1031.
*** 2003-11-30 18:55:30.984 48767 kcrr.c
kcrrfail: dest:2 err:1031 force:0 blast:1



The ERROR column in V$ARCHIVE_DEST shows ORA-01031 insufficient privileges.

Cause

The parameter DB_ALLOWED_LOGON_VERSION has not been set in the remote database.

DB_ALLOWED_LOGON_VERSION is a new parameter introduced in 10g that allows the DBA to explicitly determine which authentication protocols are allowed by the client or database.
The value specified is the earliest client version level supported by this database.
When clients earlier than the specified version attempt to connect, authentication will fail.

Solution

In the init.ora of the remote (Downstream capture) database, set the following : db_allowed_logon_version=10

Note: Bug 2981553, which is implemented in 10.1.0.2, removes the parameter db_allowed_logon_version. This is replaced by the sqlnet.ora parameter called sqlnet_allowed_logon_version.

 

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/11134237/viewspace-684397/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论

注册时间:2009-01-11

  • 博文量
    96
  • 访问量
    251540