ITPub博客

首页 > Linux操作系统 > Linux操作系统 > 在路由器上封BT和eMule的方法(转)

在路由器上封BT和eMule的方法(转)

原创 Linux操作系统 作者:jcszjswkzhou 时间:2019-03-16 18:24:03 0 删除 编辑
第一是常用的封端口的方法:
呵呵,常用的命令如下:

1禁止∶
access-list 102 deny tcp any any range 6881 6890
access-list 102 deny tcp any range 6881 6890 any
access-list 102 permit ip any any

这种方法有其局限性,一是现在有的bt软件,再封锁后会自动改端口二是我仔细研究过好几个BT下载软件,它们现在的announce端口现在已经用8000、8080的说,如果连这个也封,那网络使用就有可能不正常(我这样做过,呵呵,后来N多人打电话找我,吓得我马上DEL掉了)

第二种方法:就是用NBAR (Network-Based Application Recognition)网络应用识别
NBAR是一种动态能在四到七层寻找协议的技术,它不但能做到普通ACL能做到那样控制静态的TCP UDP的报,也能做到控制一般ACLs不能做到动态的端口的那些协议(如BT)之类.
An external Packet Description Language Module (PDLM)的文件用来扩展NBAR识别的协议。(具体我也翻译不出来,只看了个大概),
我就说说过程:
1到http://www.cisco.com/pcgi-bin/tablebuild.pl/pdlm 下载bittorrent.pdlm,(要CCO的)
2放到TFTP,然后用copy tftp disk2(大多数应该是flash)
#show runn
得到关于BT的部分是
class-map match-all bittorrent
match protocol bittorrent
!
!
policy-map bittorrent-policy
class bittorrent
drop
!
interface GigabitEthernet0/2
description CONNECT INSIDE
ip address 192.168.168.1 255.255.255.252 secondary
ip address 192.168.21.1 255.255.255.0
ip nat inside
service-policy input bittorrent-policy
service-policy output bittorrent-policy
duplex full
speed 1000
media-type rj45
no negotiation auto

我实验了一下,这样的话,BT就不能下载,呵呵
感觉目前这样的技术比较好,下面是去掉EMULE的方法。
ip nbar pdlm bittorrent.pdlm
ip nbar pdlm eDonkey.pdlm

class-map match-any bittorrent
match protocol bittorrent
match protocol edonkey
!
!
policy-map bittorrent-policy
class bittorrent
drop
!
这样的话,Emule也能K掉了,呵呵,刚刚做好.

来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/10294527/viewspace-124030/,如需转载,请注明出处,否则将追究法律责任。

请登录后发表评论 登录
全部评论

注册时间:2007-08-29

  • 博文量
    892
  • 访问量
    561318